Missing selectProduct JS function because productmenu.js is never included

RESOLVED FIXED in Bugzilla 2.18

Status

()

--
minor
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: pjdemarco, Assigned: wicked)

Tracking

2.18
Bugzilla 2.18
Bug Flags:
approval -
approval2.18 +
blocking2.18.2 +

Details

(Whiteboard: [does not affect trunk])

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Bugzilla 2.18

Going to the edit flags screen in IE 6.0 you get an error
 "A runtime error has occurred. Do you wish to debug?
Line 61 Error: Object Expected"

Also every time a product is selected a similar error pops up:
 "A runtime error has occurred. Do you wish to debug?
Line 128 Error: Object Expected"


Reproducible: Always

Steps to Reproduce:
1. Go to the edit flags screen
2. see the error
3. change product, see other error

Actual Results:  
It seems to work if you press "no" for these error dialogs.

Expected Results:  
No errors please
(Reporter)

Updated

14 years ago
Version: unspecified → 2.18
(Assignee)

Comment 1

14 years ago
Confirmed on both FF and IE. This seems to affect only v2.18, tip is working.
For some reason the generated page does not include the productmenu.js that
contains the definition for the selectProduct function.
Assignee: general → wicked
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: editflagtypes.cgi has an error in IE 6.0 "A runtime error has occurred. Do you wish to debug?" → Creating, editing and copying a flag type in editflagtypes.cgi results in errors about missing selectProduct function
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 2

14 years ago
It seems this same problem also affects Request Tracker (request.cgi). Problem
is a result of incorrect backport of bug 241814 into v2.18. It uses
javascript_urls which was added only to v2.20 in bug 251469.

We either have to backport javascript_urls to 2.18 or partially backout the
patch that changed productmenu.js inclusion in the two affected templates.
Status: NEW → ASSIGNED
Component: Bugzilla-General → User Interface
Flags: blocking2.18.2?
Summary: Creating, editing and copying a flag type in editflagtypes.cgi results in errors about missing selectProduct function → Missing selectProduct JS function because productmenu.js is never included
(Assignee)

Comment 3

14 years ago
Created attachment 180651 [details] [diff] [review]
Add javascript_urls to header template, V1

This is a backport of the javascript_urls parameter handling for the header
template that was implemented for tip in bug 251469. This patch includes kiko's
burn fix in that bug. I tested this and now the productmenu.js is correctly
included in both request.cgi and editflagtypes.cgi. Component filtering works.
Attachment #180651 - Flags: review?(myk)
Comment on attachment 180651 [details] [diff] [review]
Add javascript_urls to header template, V1

Looks good. r=myk
Attachment #180651 - Flags: review?(myk) → review+
(Assignee)

Updated

14 years ago
Flags: approval?
If I'm reading this correctly, this problem ONLY affects 2.18, and does not
affect the trunk.  Is that correct?  (Denying approval for trunk on that basis).
Flags: blocking2.18.2?
Flags: blocking2.18.2+
Flags: approval?
Flags: approval2.18+
Flags: approval-
Whiteboard: [does not affect trunk]

Comment 6

14 years ago
Checking in template/en/default/global/header.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/header.html.tmpl,v
 <--  header.html.tmpl
new revision: 1.24.2.5; previous revision: 1.24.2.4
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 7

14 years ago
language="JavaScript"
is gonna be if not already deprecated
(Assignee)

Comment 8

14 years ago
(In reply to comment #7)
> language="JavaScript" is gonna be if not already deprecated

Those have been removed for trunk (see bug 282999) but not from v2.18 branch. I
used it in my patch so the inserted script tags are same as those generated for
javascript param.

(In reply to comment #5)
> If I'm reading this correctly, this problem ONLY affects 2.18, and does not
> affect the trunk. Is that correct?

Yes. Trunk is not affected because javascript_urls param is already in it and so
the previous fix in bug 241814 works nicely there.
(Assignee)

Comment 9

14 years ago
*** Bug 285499 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

14 years ago
*** Bug 295960 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.