Need ability to write/create JAR files

RESOLVED DUPLICATE of bug 379633

Status

()

Core
Networking
--
enhancement
RESOLVED DUPLICATE of bug 379633
13 years ago
10 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
For the XUL Developer Kit, I need the ability to write/create JAR files. If all
else fails, I can use a standalone zip utility and nsIProcess, but I was really
hoping to get it integrated with our libJAR impl and necko streams, etc.

Comment 1

13 years ago
Let´s keep this separate from the existing libjar, as that is optimized for
reading, including caching and such. 
But a separate JarWriter could possibly be added to top, using a ZipReader as
input. Note that writing zip files is a completely different thing...
(Reporter)

Comment 2

13 years ago
That's fine with me; we'll probably need to provide granular hooks to clear the
JAR cache.
Keywords: helpwanted

Comment 3

10 years ago
This is a fine idea and one that I could really use ... A companion component to nsIZipReader named (of course) nsIZipWriter.  I wrote an extension that backs up Firefox and rebuilds extensions as .xpis.  Currently, I use nsIProcess to run batch files that call a third-party archive utility - three different binaries for each of Windows, *nix, and OSX.  It works, but is bloated and messy and accounts for the vast majority of support issues.

Christopher Ottley created MAF (Mozilla Archive Format, http://maf.mozdev.org/), but development seems to have stalled.
Chuck, reference bug 379633.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379633
You need to log in before you can comment on or make changes to this bug.