{inc}Clicking submit button inside div fails due to redraw

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Aaron Sherman, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

I have a div inside of a table cell, which contains a form. The div has a
painted border. For some reason the confluence of these three factors leads to
the problem where pressing a submit button fails because the button location is
re-calculated when pressed and it is wrapped to the next line on button-down!
Example html will be attached.

Reproducible: Always

Steps to Reproduce:
1. Load attached HTML
2. Try to press submit button
3.

Actual Results:  
Button wraps down to next "line" on button-down

Expected Results:  
I expected that button location would not change and button would activate form.

Removing the div border or table solves the problem.
(Reporter)

Comment 1

13 years ago
Created attachment 180409 [details]
This HTML example demonstrates the button-wrapping problem

Updated

13 years ago
Component: General → Layout: Form Controls
Keywords: testcase
Product: Firefox → Core
Version: unspecified → 1.0 Branch

Updated

13 years ago
Assignee: firefox → nobody
QA Contact: general → layout.form-controls

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Clicking submit button inside div fails due to redraw → {inc}Clicking submit button inside div fails due to redraw
Whiteboard: [reflow-refactor]
Version: 1.0 Branch → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
Ah, this WFM in a pre-refolw branch build aswell
I see no movement of the button when pressing it in either of these builds:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)

Comment 5

12 years ago
WFM, SeaMonkey 2006120701 (pre reflow branch) and 2006120801 (post) on Linux.
(bug is reproducible in Mozilla 1.6 on Linux)

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.