Proxy authentication is not requested when download manager window is open

RESOLVED DUPLICATE of bug 260186

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 260186
14 years ago
10 years ago

People

(Reporter: Tiago Pichi Barboza, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

I need to authenticate every time I open the browser. But when I begin a
download and close the browser main window (and leave the download manager
window opened finishing the download), if I re-open the browser, it does not ask
me for the password again, it logs on automaticaly using the last user that have
been logged (the user that is using the download manager). It means that another
user in my repartition can use my workstation´s  browser with my user logged in
if I leave it  for a second.

Reproducible: Always

Steps to Reproduce:
1. Open the browser and authenticate into a proxy.
2. Start a big download. 
3. close the browser main window. (leave the download manager opened)
4. Open the browser again, and it won´t request the password again.
Actual Results:  
It doesn´t request the proxy password.

Expected Results:  
It should have had requested a new authentication.

I´m behind a authenticate proxy. I believe it´s a critical problem, because
another user can surf the net with my username logged in, and maybe some
unauthorized access can be reported to the network admin with my name.
There are extensions that provide UI for the logout feature (WebDeveloper is
one). There are two related bugs, bug 260186 covers some logout functionality,
bug 260839 is requesting some sort of finegrained logout ability. The
functionality currently available in extensions is simply "log out of all http
auth".

Bug 117222 is a similar issue related to cookie-based logins.

*** This bug has been marked as a duplicate of 260186 ***
Group: security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.