Remaining instances of "Firefox" in unbranded builds

RESOLVED DUPLICATE of bug 269460

Status

RESOLVED DUPLICATE of bug 269460
14 years ago
7 months ago

People

(Reporter: gerv, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(URL)

In unbranded builds (i.e. without --enable-official-branding), the following
instances of the word Firefox were found:

> 1.
browserconfig.properties:browser.startup.homepage=http://www.mozilla.org/products/firefox/central.html
> 2.
browserconfig.properties:browser.startup.homepage_reset=http://www.mozilla.org/products/firefox/central.html
> 3. components/nsExtensionManager.js:         " location. While you can run
Firefox like this, it is recommended" + 
> 4. components/nsBrowserContentHandler.js:  helpInfo : "Usage: firefox [-flags]
[<url>]\n",
> 5. README.txt:For information about installing, running and configuring Firefox 
> 6. README.txt:refer to: http://getfirefox.com/releases/
> 7. browser/content/browser/credits.xhtml:          Mozilla Firefox&trade; and
the Firefox logo are trademarks of the Mozilla
> 8. browser/content/browser/credits.xhtml:          Firefox name or logo.</p>
> 9.
en-US/locale/en-US/mozapps/extensions/extensions.properties:globalItemList=The
following items are available to all users. \nYou can start Firefox with
-lock-item "{GUID}" to prevent users from uninstalling or disabling an item. To
unlock an item, start Firefox with -unlock-item "{GUID}"
> 10. en-US/locale/browser/aboutDialog.dtd:<!ENTITY copyrightText         
"&#169;1998-2005 Contributors. All Rights Reserved. Firefox and the 
> 11. en-US/locale/browser/aboutDialog.dtd:                                
Firefox logos are trademarks of the Mozilla Foundation.  All rights 
> 12.
en-US/locale/browser-region/region.properties:homePageDefault=http://start.mozilla.org/firefox
> 13. Various bookmarks and search plugin URLs refer to Firefox.

Gerv
Blocks: 286149
Also the image in the about dialog (/browser/base/branding/about.png) contains
the text firefox.

Comment 2

14 years ago
Marking dup of bug 269460, which has the beginnings of the build-config
necessary to make this happen.

*** This bug has been marked as a duplicate of 269460 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.