forms autofill buggy and annoying

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: crmcneill, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Firefox forms autofill doesn't work reliably.  Would like to see IE's autofll
behavior emulated, as it makes complete sense.  Current Firefox behavior works
in some form field and not others; isn't always "smart" as to what kind of field
it is.  Would be better to have an editable forms "master" rather than current
"remember forms" action; then to also have additional 2nd-priority autofill
options.  

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
WONTFIX INVALID 

Current Auto-complete works fine IMHO

Please be specific if you want to report a bug ...
It doesnt work like "some-other-browser" is not a bug

Comment 2

13 years ago
WFM

Please reopen when you can provide url or a testcase showing what the issue is. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.