Attachments with "Content-Disposition: attachment" shows automatically

RESOLVED DUPLICATE of bug 147461

Status

--
minor
RESOLVED DUPLICATE of bug 147461
14 years ago
14 years ago

People

(Reporter: musiphil, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla Thunderbird version 1.0.2 (20050317)

Attachments with "Content-Disposition: attachment" is displayed automatically in
the message window, but it shouldn't, as opposed to those with
"Content-Disposition: inline".

From RFC 2183 <http://www.faqs.org/rfcs/rfc2183.html>:

2.1  The Inline Disposition Type

   A bodypart should be marked `inline' if it is intended to be
   displayed automatically upon display of the message.  Inline
   bodyparts should be presented in the order in which they occur,
   subject to the normal semantics of multipart messages.

2.2  The Attachment Disposition Type

   Bodyparts can be designated `attachment' to indicate that they are
   separate from the main body of the mail message, and that their
   display should not be automatic, but contingent upon some further
   action of the user.  The MUA might instead present the user of a
   bitmap terminal with an iconic representation of the attachments, or,
   on character terminals, with a list of attachments from which the
   user could select for viewing or storage.


Reproducible: Always

Steps to Reproduce:
1. Compose a message and attach a plain text file.
2. Save the message as a draft.
3. Exit Thunderbird.
4. Open "Drafts" in "Local Folders" in your profile directory.
5. Edit the Content-Disposition header of the attachment so that it looks like:
> Content-Disposition: attachment; filename="example.txt"
6. Open Thunderbird and see the message in the Drafts folder.
Actual Results:  
The contents of the attachment is shown automatically without any user action.

Expected Results:  
The contents of the attachment should not be shown automatically but with some
user action.

Comment 1

14 years ago
see bug 185618

Comment 2

14 years ago



*** This bug has been marked as a duplicate of 147461 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.