recipient in answer is wrong

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Florian Effenberger, Assigned: Jungshik Shin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Thunderbird 1.0.2

I have a message where, when I reply, the recipient is only "S". I guess TB gets
corrupted when reading the headers of the original message.

Reproducible: Always

Steps to Reproduce:
1. Reply to this message
Actual Results:  
To: S

Expected Results:  
To: Real Mail Address

I have NOT attached the .eml file of the original message due to privacy issues.
Please contact me via PM or give me an email address where I can send it to.

Comment 1

13 years ago
Please mail me a copy of the problem mail (Forward as Attachment).

Comment 2

13 years ago
Thanks for the sample mail, Florian.  Is your Windows installation also Deutsch?

Hm.  With TB 1.0.2, Win2K, all en-US, I get the entire From: address quoted into 
the To: on replying to that sample.

But with TB 1.0+0407, the From: is entirely blank, not even the "S".  It's 
possible the difference I'm seeing between the two is related to the fix for 
bug 229399.

The From: header has an (illegal) 8-bit character in it:
  From: "Sümmerer, Jan" <Jan.Suemmerer@******.de>
In fact, the message has an error header pointing this out.
(Assignee)

Comment 3

13 years ago
Mike, can you forward the sample to me? 
(Reporter)

Comment 4

13 years ago
Hi Mike,

thanks for checking! I run Thunderbird 1.0.2, US release with German langpack
from www.thunderbird-mail.de, and Win XP SP2 German.

Florian

Comment 5

13 years ago
Jungshik, did you find anything out when I sent you the sample message?
(Assignee)

Comment 6

13 years ago
Mike, sorry for the delay.  With TB 1.1alpha2 (2005-07-12), what's reported can
happen if 'View | Character Encoding' is set to UTF-8. If it's correctly set to
'ISO-8859-1', it doesn't happen. The message in question does not have any
Content-Type header. Neither does it have RFC2047-compliant header (it has raw
8bit characters as pointed out by Mike)

Florian,  what's 'View | Char. Encoding' set to when you have this problem? 

Mike, I can't reproduce symptoms experienced by you. What's you setting for the
character encoding of outgoing messages? 
Assignee: mscott → jshin1987

Comment 7

13 years ago
(In reply to comment #6)
> Mike, I can't reproduce symptoms experienced by you. What's you setting for
> the character encoding of outgoing messages?

I can't reproduce them either.  If I'd thought to tweak the encodings when I 
initially tested, I would have listed the results here.  Now: in Thunderbird 
(both 1.5b1-0904 and 1.6a1-0904), whether the reply is initially encoded as 
UTF-8 or ISO-8859-1, the To: field is filled in as expected.  I don't know 
what's changed...
(Reporter)

Comment 8

13 years ago
Sorry, don't know anymore, it's been too long... ;(

Comment 9

12 years ago
Never could reproduce this successfully; setting to WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.