lines are not broken after a "-" sign as in Internet Explorer nad Opera

RESOLVED DUPLICATE of bug 95067

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 95067
13 years ago
13 years ago

People

(Reporter: jurek, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

On the url you see the text content table with a width of 88% within a td-cell
of a fixed major table is expanded to the size of the major table, because the
email addresses with a "-"-sign in it are not line-broken after the "-" sign.
Please compare to Opera and Internet Explorer.

Two bugs are in it in my opinion:
- Long words with a "-" sign should be line-broken after this sign if the x-size
of the word is longer than the table cell.
- The table of 88% width and center-align should never be expanded to the size
of the major table cell.


Reproducible: Always

Steps to Reproduce:
1. open url in Firefox, Opera and Internet Explorer
2. Watch the text table width

Actual Results:  
The text table is expanded to the size of the major table cell

Expected Results:  
The table should not be expanded, the emails should be broken after a "-" sign.

Comment 1

13 years ago
Line-breaking after hyphens is bug 95067.  

The HTML on the page referenced doesn't pass the W3 validator, so whether 
the "correct" table behaviour is to expand or not, I don't know.

As the summary you've put is about hyphens, I'm going to dupe to bug 95067.  if 
you don't agree, please reopen the bug.

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.