when saving an image attachment via the mail window with Save image as... the download never completes

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Ville Mattila, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

If there is any image files attached, the images are shown in the main mail
window after the message text itself. When trying to save those images by
right-clicking the image and selecting "Save Image As..." from the popup menu,
the download starts and processes through to 100%, but never completes. Only way
to close the download window is to press Cancel. The file will not be saved.

The bug appears from the embedded mail window below the message list, as well as
from the standalone window.

The message is downloaded from an IMAP server, the message is not cached to the
local drive.

Reproducible: Always

Steps to Reproduce:
1. Open a message with one or more image attachments
2. Try to save any of the images by right-clicking it and selecting "Save Image
As..."

Actual Results:  
The download window opens and the download process begins, goes through to 100%
but never completes.

Expected Results:  
Complete the download and save the file.

Comment 1

12 years ago
This bug has been reported by a debian user too:

 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=325140

... is this a dupe?

Comment 2

12 years ago
Using Thunderbird 1.0.6 (20050716), I also had trouble saving an image - I get the stuck on 100% thing too. 

When I looked at the message source, I noticed "Microsoft Exchange" and "multipart/alternative" was mentioned. The message was composed HTML and the image I was trying to save was part of the body, rather than a separate attachment.

The part relating to the image looked like this:

------_=_NextPart_002_01C5D061.AA38A5F2
Content-Type: image/gif;
	name="image001.gif"
Content-Transfer-Encoding: base64
Content-ID: <image001.gif@01C5D0A4.B77DDC20>
Content-Description: image001.gif
Content-Location: image001.gif

I will attach an image showing the download manager stuck at 100%.

Comment 3

12 years ago
Created attachment 200958 [details]
Image showing "save image as" stuck at 100%

Comment 4

12 years ago
Re comment#2 - I forgot to say I run Thunderbird on Windows XP and collect mail using IMAP (Courier IMAP).

Comment 5

12 years ago
Have you tried 1.5beta2?

An IMAP protocol log of a session where the save fails to complete might be useful as well.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Comment 6

12 years ago
I loaded Firefox 1.5, and this Thunderbird issue seems to be fixed now. Now after a download the "Launch File" and "Show Download Location: buttons are enabled, and the file does end up on disk.

Comment 7

12 years ago
I have this problem in 1.5rc1 as well. It is fixed in 1.5rc2. Even in rc1 the file does save if you just close the window using the x.

Comment 8

12 years ago
Ville Mattila, comment 7 states that this problem was fixed in 1.5RC2 (and so should also be fixed in the release of 1.5).  Are you still experiencing this problem?

Comment 9

12 years ago
No response from reporter  => WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.