Bug in javascripts Date::toLocaleString()

RESOLVED DUPLICATE of bug 153586

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 153586
13 years ago
13 years ago

People

(Reporter: Damjan Georgievski, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; mk-MK; rv:1.7.6) Gecko/20050322 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; mk-MK; rv:1.7.6) Gecko/20050322 Firefox/1.0.2

This javascript code is simplified from what's on palnet.mozilla.org:
now = new Date();
now.toLocaleString();

The problem is that on Linux, with a UTF-8 locale (mk_MK.UTF-8), the
toLocaleString returns garbage. Some experiments show that the UTF-8 string
returned by the C library is then converted from iso-88591 to UTF-8 - this
conversion doesn't make any sense.


Reproducible: Always

Actual Results:  
вÑо, 12 Ð°Ð¿Ñ 2005 14:43:00 CEST

Expected Results:  
вто, 12 апр 2005 14:43:00 CEST

Comment 1

13 years ago
Dup of bug 83092?

Comment 2

13 years ago
Damjan, please see bug 153586 comment 82. Try this on a recent nightly trunk
build and reopen if you can reproduce the error.

*** This bug has been marked as a duplicate of 153586 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
g(In reply to comment #2)
> Damjan, please see bug 153586 comment 82. Try this on a recent nightly trunk
> build and reopen if you can reproduce the error.

The bug is solved in trunk versions... any chance of this getting in to 1.0.3 or
1.0.4?

Comment 4

13 years ago
1.0.3 is definitely locked down for security work only and I believe that
further development on the 1.7 branch is limited as well.
You need to log in before you can comment on or make changes to this bug.