css rule "tag1:hover > tag2 { display: block; }" is broken when tag2 display is set to none with javascript

RESOLVED INVALID

Status

()

Core
DOM: CSS Object Model
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Jasper de Vries, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050410 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050410 Firefox/1.0+

if a testcase is needed I can add one tonight (CET)

Reproducible: Always

Comment 1

13 years ago
Created attachment 180484 [details]
testcase - visibility

Comment 2

13 years ago
Actually, I think this is invalid. Using .style sets the STYLE attribute value
which overrides the CSS value because it is more specific...

Please attach a testcase if you thought of something different.

Updated

13 years ago
Keywords: testcase

Comment 3

13 years ago
Note that this bug is INVALID. It is probably a DUPLICATE.
Whiteboard: DUPEME

Comment 4

13 years ago
Resolving INVALID. Please
see: <http://www.w3.org/TR/2000/REC-DOM-Level-2-Style-20001113/css.html#CSS-htmlelementcss>
"Inline style information attached to elements is exposed through the style
attribute."

Following the normal cascade rules that means Mozilla is doing the right thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.