If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

thunderbird crashes after 10 minutes with large mailbox

RESOLVED DUPLICATE of bug 289987

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 289987
13 years ago
13 years ago

People

(Reporter: Nick Amato, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7.5) Gecko/20041209 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.7.5) Gecko/20041209 Firefox/1.0

Thunderbird 1.0.2 crashes under NetBSD when viewing my large IMAP mailbox.  It
crashes every time, with the following backtrace:

#0  0x4884260b in kill () from /usr/lib/libc.so.12
#1  0x4886c77a in raise (s=11) at /usr/src/lib/libc/gen/raise.c:48
#2  0x08054cfd in nsProfileLock::FatalSignalHandler ()
#3  0x48819f8a in pthread__signal_tramp (handler=<incomplete type>, 
    info=<error type>, uc=<incomplete type>)
    at /usr/src/lib/libpthread/pthread_sig.c:938
#4  0x48867eac in swapcontext () from /usr/lib/libc.so.12
(gdb) 

The specific details of my mailbox setup are:

- 2 IMAPS mailboxes, both large (> 1000 messages each, 200MB size each)
- Microsoft Exchange Server on the server side
- NetBSD-current
- Many message filters (~15)
- Well-exercised learning file (training.dat size 1008181 bytes)

I would be happy to send a core file.


Reproducible: Always

Steps to Reproduce:
1.Configure a large imaps mailbox with Microsoft Exchange server with ~15
message filter rules.
2.Wait approximately 10 minutes.

Actual Results:  
Thunderbird crashed with the above backtrace.

Expected Results:  
No crash.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0

Comment 1

13 years ago
any talkback reports? Do you have talkback installed? Can you try generating an
imap protocol log. Whatever happens right before the crash might be interesting
- http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Comment 2

13 years ago
reporter: frames 4-10 are more important ...

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 289987 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
To answer the questions, frames 4-10 were not available due to gdb crashing:

gdbtypes.c:528: internal-error: make_cv_type: Assertion `TYPE_OBJFILE (*typeptr)
== TYPE_OBJFILE (type) || TYPE_STUB (*typeptr)' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n)

This occurred in bogh gdb 5.3nb1 and 6.2.1.

I will attempt to get an imap server file and post it here.  I realize the bug
is resolved/duplicate, but this will be for your information as you see fit. 
Thanks.
(Reporter)

Comment 5

13 years ago
The end of the IMAP log is (sanitized):

1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: * 17280 FETCH
(UID 34863 RFC822.SIZE 11997 FLAGS (NonJunk) BODY[HEADER.FIELDS ("FROM" "TO"
"CC" "SUBJECT" "DATE" "MESSAGE-ID" "PRIORITY" "X-PRIORITY" "REFERENCES"
"NEWSGROUPS" "IN-REPLY-TO" "CONTENT-TYPE")] {229}^M
1293942784[98f4b00]: 9195c00:not.other.realhost.com:S-SPAM:STREAM:OPEN Size:
11997: Begin Message Download Stream
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=27 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: From:
nkufjekxv@yahoo.com^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=25 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: Subject: [SPAM:
25.91] ^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=44 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: Date: Thu, 6 Jan
2005 13:11:08 -0800 (PST)^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=58 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: Message-Id:
<200501062111.j06LB8mZ009943@not.other.realhost.com>^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=73 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: Content-Type:
multipart/mixed; boundary="----------=_41DDA992.A56EEC21"^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=2 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: ^M
1293942784[98f4b00]: ReadNextLine [stream=9944708 nb=3 needmore=0]
1293942784[98f4b00]:
9195c00:not.other.realhost.com:S-SPAM:CreateNewLineFromSocket: )^M
1293942784[98f4b00]: 9195c00:not.other.realhost.com:S-SPAM:STREAM:CLOSE: Normal
Message End Download Stream

In this case we actually aborted, not crashed, but gdb was still unable to read
the backtrace:

(gdb) bt
#0  0x4884260b in kill () from /usr/lib/libc.so.12
#1  0x488e408f in abort () at /usr/src/lib/libc/stdlib/abort.c:82
gdbtypes.c:528: internal-error: make_cv_type: Assertion `TYPE_OBJFILE (*typeptr)
== TYPE_OBJFILE (type) || TYPE_STUB (*typeptr)' failed.

You need to log in before you can comment on or make changes to this bug.