If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Send Options, Text Format not considered when called directly from external application (File Maker), without opening the Compose window

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Dana Benciu, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

I am trying to send e-mails automatically from File Maker, using Thunderbird as
the default mail application, but when I do not have the Compose window open
(there is an option called "Perform without dialog" for the SendMail function in
File Maker), the "Convert the message to plain text" does not work, it is sent
as "Content-Type: text/html" instead of "Content-Type: text/plain".

This problem does not appear if I allow the Compose window to be open and click
on Send, which I prefer not to do because of many messages to be sent at once,
possibly hundreds.


Reproducible: Always

Steps to Reproduce:
1. Select Tools/Options
2. Select Composition/Send Options
3. Select Convert the message to plain text

Actual Results:  
I got a supposed to be text message, but as HTML layout, no breaks, no new
lines, everyhing is in one (displayed) row.

Expected Results:  
I suppose that if I choose this option, the message should be delivered as
"Content-Type: text/plain", instead of "Content-Type: text/html".

Well, it is not a crash actually, it's about functionality, and this issue is
very important to our organization.

Comment 1

13 years ago
this is fixed in trunk builds, so the next release of the Suite and Tbird 1.1
will have the fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.