XP Add/Remove Software keeps ALL versions of Firefox listed, but uninstall removes everything

RESOLVED DUPLICATE of bug 247884

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 247884
13 years ago
13 years ago

People

(Reporter: Robbie Sinclair, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

When using Windows XP (Service Pack 2) Add/Remove Software control panel, every
release version of Firefox is listed (1.0, 1.1, etc.) Each lists the filesize as
well, and they're different, which makes it look (from Windows) like there are
multiple copies of Firefox installed.

However, when I attempt to "uninstall" prior versions, it removes all versions,
including the most current. Actually, after the first version is uninstalled,
subsequently attempting to uninstall the other versions gives an error that they
can't be found.

When new release versions of Firefox are installed, they should NOT keep adding
new entries to the Add/Remove Software control panel. No other software does
this. Additionally, attempting to remove these prior versions should NOT remove
 what appears to be the single installation of Firefox installed.


Reproducible: Always

Steps to Reproduce:
1. Go to Windows XP Control Panel: Add/Remove Software
2. Find multiple entries for Firefox release installs (1.0, 1.1, etc.)
3. Attempt to uninstall earlier release versions. Current (and only) install is
uninstalled, completely removing Firefox from system. Must redownload and
reinstall from web.

Actual Results:  
When attempting to uninstall prior release versions of Firefox, all versions are
uninstalled, including most current version. Requires redownloading and
reinstallation of browser software from web.

Expected Results:  
Windows XP Control Panel Add/Remove Software should list only ONE instance of a
Firefox install.

If release version control must be separated like this for some reason (causing
Win XP to list each release version as uninstallable) then using that uninstall
should ONLY remove the intended release version, not all versions. Easiest
solution is to not have Win XP list all previously installed releases as
separate entities, which prompts users to want to uninstall past versions.
This has been fixed in 1.0.3.

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.