Cannot select default plugin for a specific file type.

RESOLVED DUPLICATE of bug 19118

Status

--
major
RESOLVED DUPLICATE of bug 19118
14 years ago
4 years ago

People

(Reporter: raid517, Assigned: doronr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)

Hi I would like a way to select a default plug in for a specific file type. I
have a number of plugins installed in my Linux Debian system for Firefox. These
include mplayer plugin, kaffeine plugin and vlc plug in. Most of these plugins
claim to do  a very similar job - but some handle some sites better than others.
However ATM I can only use whatever plugin happens to be at the top of the list
in the 'about plugins' directory for whatever default file type that that plugin
claims to be able to handle. The only way to change this behaviour and to select
a default plugin for a particular web site is to go to the the firefox plugins
directory and disable all other plugins other than the one I know can handle the
streaming media from that site best. Which all in all is a very tiresome and
cumbersome process.

What is needed is not only a way to specify which plugins should handle which
file types - but also which plugins should be used (or accociated) with specific
web sites I choose to visit. Eg perhaps there could be some kind of popup dialog
asking 'Please select a plugin for xyz file type.' Then another asking 'always
use this plugin for this file type?' and another asking 'Only use this plugin
when visiting this site?'

This is therefore both a feature request and a bug report - as currently the
plugin setup in Linux seems very untidy an inneficient.

Thanks for the great work!

GJ

  

Reproducible: Always

Steps to Reproduce:
1.Install vlc, mplayer and kaffeine plugins
2.Visit bbc.co,uk/news and play video, select change how this video is viewed at
the bottom left of the player window. Go to www.nakednews.com and try out the
various suppoted codecs.
3.Mess about with embeded streaming video on the web in general.

Actual Results:  
Some plugins work for certain sites, while others do not You cannot select a
default plugin for a specific file type on a specific web site.

Expected Results:  
It should have asked me which plugin to use and whether it should use that
plugin for all sites, or just that specific site.

(This would also be a good way of improving security - as you could then
disallow specific untrusted sites from using Java and Flash animations).
manager your plugins is bug 19118
per site bassis will not be implemented

*** This bug has been marked as a duplicate of 19118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.