Clicking a broken link performs Google's "I'm Feeling Lucky!" search

RESOLVED DUPLICATE of bug 310826

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 310826
13 years ago
13 years ago

People

(Reporter: Vesa Piittinen, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi-FI; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi-FI; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

When clicking a broken link that begins with http://, Firefox performs a "I'm
Feeling Lucky!" search. This shouldn't happen as links are meant to be a
pointers to elsewhere on the web, not search keywords to Google. An error page
should be displayed instead. This bug causes a lot of confusion to inexperienced
computer users.

Reproducible: Always

Steps to Reproduce:
1. find or make a page with a broken link that begins with http://
2. click the link
Actual Results:  
A Google's "I'm Feeling Lucky!" was performed and the webpage was shown that
matches the keywords.

Expected Results:  
Shown an error page of a malformed link.
i think its the same like 231720

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 2

13 years ago
no, it's bug 233541
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 233541 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
No, it's a dup of bug 310826 ;)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 310826 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.