cache options browser does not always automatically refresh webpage everytime

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Chad Berger, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Firefox does not automatically refresh when using changes are made to a web page
when it should just like Mozilla does. It should refresh the page everytime a
change is made. The window the changes are made to needs to be open when you
push f5 to refresh it properly. When it should be automatic 

Reproducible: Always

Steps to Reproduce:
1.open an HTML Window 
2.Make an image change or drastic change
3.save changes close window and reopen it 
Actual Results:  
the change shouldn't have taken effect that is the problem then while the window
is open push f5 and the changes will take place but that is the only way the
changes show up.


Expected Results:  
should automatically refresh everytime each time you make a change with out
having to push f5
There is a preference (hidden in Firefox, but not in Mozilla) that allows this
to be specified.  

However, always going back to the server is undesirable in many cases for speed
of browsing. which is why the default in both browsers is to use the cache
settings.  The server can specify to not use cache for a page, so web apps
relying on that type of behaviour should do that.

Marking INVALID, this is an option, but is not default.  We're not going to
change the default either, for the reasons above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
I think the big problem lies with Firefox not allowing us to control the cache,
as Mozilla does with the options in Advanced->Cache "Compare the page in the
Cache to the page on the Network: Every time I view the page".

It may not be the best thing in the world to do, but when one is working on a
web site, it very useful.  I agree it should no be the default.
use about:config to set browser.cache.check_doc_frequency

values:

1 = Every time I view the page
0 = Once per session
3 = When the page is out of date (default)
2 = Never
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.