click one message and select all = marked as read

RESOLVED DUPLICATE of bug 233027

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 233027
13 years ago
13 years ago

People

(Reporter: Jean-Sébastien Goupil, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

When you are in the main window, if you click on only one message and
immediately you select all (with CTRL+A), all messages will be marked as read

Reproducible: Always

Steps to Reproduce:
1. Have a lot of unread messages
2. Click on a unread message
3. Immediately, press CTRL+A (but not too rapidly !)
4. All messages will be selected and marked as read.

Actual Results:  
All messages are marked as read

Expected Results:  
just select all

Comment 1

13 years ago
This is easy to reproduce if you've set a delay in marking messages read:
 Tools | Options | Advanced | General
   [] Wait [N] seconds before marking a message as read

(That's how the option appears in trunk builds...)

Assuming that's what reporter has done, I'm duping this.

*** This bug has been marked as a duplicate of 233027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.