Can't press Esc to skip "associated words" selector when entering Chinese Text in textbox/Google search field

RESOLVED WORKSFORME

Status

Camino Graveyard
OS Integration
P3
minor
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: CH Chan, Assigned: Simon Fraser)

Tracking

unspecified
Camino1.0
PowerPC
Mac OS X

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050414 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050414 Camino/0.8+

In ordinary Mac OS apps, One can press Esc to skip "associated words selector"
after entered one chinese character. (If "Show associated words" have been turn
on in Input menu)
In Camino, "Associated words selector" cannot be skipped by pressing Esc.


Reproducible: Always

Steps to Reproduce:
1.enter a chinese word
2.a "associated words selector" pop-up
3.Press Esc


Actual Results:  
"Associated words selector" can't be skipped

Expected Results:  
"Associated words selector" should be skipped (in Firefox, Safari and other Mac
OS Apps)
Is this a duplicate of bug 287866?

I'm not familiar enough with the Asian input methods to know what to do to
reproduce this, but I do know Wevah did some recent work with the Esc key that
has been blamed for bug 287866.

CH Chan, if you can't tell if this is a duplicate of bug 287866, can you provide
some detailed steps we non-Chinese speakers can use to reproduce this issue?
(Reporter)

Comment 2

13 years ago
It is similar to bug 287866

I can't confirm this bug is a duplicate of 287866. I don't if it is Chinese specific or all CJK systems are 
affected.

Reproduce the bug (detail)

In Mac OS 10.3.8

1. In system preference => International => Input menu, enable "traditional chinese" and "show input 
menu in menu bar"
2. You will see a little flag in right hand corner of menu bar. Click it, select traditional Chinese.
3. Click that little icon again, confirm "show associated words" and "Jianyi" is enabled.
3. In camino text box/google search field, type in NW and press 1. A chinese character will be added.
4. Then, a little "Associated words selector" will be popup. You can press the number to add extra 
words. If you don't need it, normally you can press Esc to skip it. But you can't in Camino.

(In reply to comment #1)
> Is this a duplicate of bug 287866?
> 
> I'm not familiar enough with the Asian input methods to know what to do to
> reproduce this, but I do know Wevah did some recent work with the Esc key that
> has been blamed for bug 287866.
> 
> CH Chan, if you can't tell if this is a duplicate of bug 287866, can you provide
> some detailed steps we non-Chinese speakers can use to reproduce this issue?

Comment 3

13 years ago
Yeah, I think it's my fault. I also think the proposed patch in bug 287866 is
the right way to do it (check to see if we're in IME and then don't eat the
escape key; it just needs to be reworked a bit), though I'm not sure that
everyone shares my opinion on it.
Thanks for the instructions (note to others not familiar with how IMEs work: you
need to enter lowercase nw, not uppercase); it reproduces.

I'll go ahead and confirm and let Wevah decide if it's a dupe or dependant or
what :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
There were just some changes to the Google search bar. Any chance they
"accidentally" fixed this?
(Assignee)

Comment 6

13 years ago
This works fine in the Google search bar in the toolbar, but not in the content.
Assignee: mikepinkerton → sfraser_bugs
Priority: -- → P3
Target Milestone: --- → Camino1.0
(Assignee)

Comment 7

13 years ago
Actually, Escape works fine in the content (e.g. on google web page) (and bug
308471 fixes the input window position).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.