Closed Bug 290457 Opened 19 years ago Closed 19 years ago

Nightly Build installer fails with Cross-Platform COM: -229 SCRIPT_ERROR

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 290312

People

(Reporter: mellingham, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.6) Gecko/20050321 Firefox/1.0.2

When trying to install nightly build from 4/14/05 the following error displayed:
Cross-Platform COM: -229 SCRIPT_ERROR
Installer window hangs and must be closed manually.

Reproducible: Always

Steps to Reproduce:
1.Download latest nightly build
2.Run installer
3.Watch it error

Actual Results:  
Content of install_status.log:

---------------------------------------------
Start Log: 15/04/2005 - 14:14:08
    System Info:
        OS Type: NT51
        Major Version: 5
        Minor Version: 1
        Build Number: 2600
        Extra String: Service Pack 2
        Total Physical Memory: 515564KB
        Total Available Physical Memory: 128648KB

    Product Info:
        Install mode: Normal
        Company name: Mozilla
        Product name (external): Mozilla Firefox
        Product name (internal): Mozilla Firefox
        Uninstall Filename: UninstallFirefox.exe
        UserAgent: 1.0 (en-US)
        Alternate search path: 

    Components corrupted (startup):
        none

    Destination Path:
        Main: C:\Program Files\Mozilla Firefox\Nightly
        SubPath: 

    Setup Type: &Custom

    Components selected:
        Cross-Platform COM
        Firefox Browser (Required)
        Mozilla Uninstaller
        en-US Language Pack
        Firefox Help (Required)
        Quality Feedback Agent (Required)

    Components to download:
        Cross-Platform COM found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        Firefox Browser found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        Mozilla Uninstaller found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        en-US Language Pack found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        Firefox Help found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        Quality Feedback Agent found: C:\DOCUME~1\MATTEL~1\LOCALS~1\Temp\7zS1D.tmp\
        **
        ** All components have been found locally.  No components will be
downloaded.
        **


    Uncompressing Xpcom Succeeded: 0

    XPInstall Start
        Cross-Platform COM: -229 SCRIPT_ERROR
    XPInstall End
-------------------------------------------

Expected Results:  
Installed the lastest nightly build

Have tried installing to another dir, after reboot etc. All reproduce error.

*** This bug has been marked as a duplicate of 290312 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.