"View -> Hide/Show Toolbar" shortcut should use shift instead of option.

RESOLVED FIXED

Status

Camino Graveyard
Toolbars & Menus
--
trivial
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Wevah, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({fixed1.8})

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

13 years ago
Since "Hide/Show Toolbar" is currently command-option-T, it hides or shows the
toolbars on *all* windows instead of just the front one (because Cocoa
interprets option as "apply to all" for certain window commands; option-click
the toolbar widget or the close/minimize/zoom buttons to see).

Changing it to use shift instead of option fixes this. If this change is made,
"Hide/Show Bookmark Bar" should probably be changed to use shift instead of
option as well, for consistency.

Comment 1

13 years ago
In defence of the current method, the Mac OS X Finder works the exact same way.

cl
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> In defence of the current method, the Mac OS X Finder works the exact same way.
> 
> cl

The Mac OS X Finder is a consistency nightmare. This is *not* how it works for
the majority of multiwindow OS X applications. Try it.
(Reporter)

Comment 3

13 years ago
Er, maybe I misinterpreted your comment. Point is, *everything* treats
option-click of the toolbar widget as "apply to all windows of this type". The
keyboard shortcut should only apply to the current window.

Comment 4

13 years ago
Created attachment 183631 [details]
New mainMenu nib file.

This is an easy fix. By using shift instead of alt for the shortcuts all of the
issues are fixed.

Updated

13 years ago
Attachment #183631 - Flags: superreview?(pinkerton)
(Assignee)

Comment 5

13 years ago
this would seem like an apple bug then, no? can we duplicate it in a sample app?
(Reporter)

Comment 6

13 years ago
I'm sure it's reproducable in a test app. It's just that Cocoa (maybe Carbon,
too) treats anything involving option+a window action as "apply to all": Window
closing, minimizing, zooming, and showing/hiding the toolbar.
(Assignee)

Comment 7

13 years ago
while using shift does "fix the glitch", it then makes us inconsistent with the
show/hide bookmarks toolbar, which is cmd-opt-b. 

thoughts?
(Assignee)

Comment 8

13 years ago
Comment on attachment 183631 [details]
New mainMenu nib file.

sr-
Attachment #183631 - Flags: superreview?(pinkerton) → superreview-

Comment 9

13 years ago
I think Command-Shift-T for Hide/Show toolbar is more consistent with other apps.

Comment 10

13 years ago
Command-Shift-B is not used so could be used for Hide/Show Bookmark Bar
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> Command-Shift-B is not used so could be used for Hide/Show Bookmark Bar

This is what Jasper and I agreed upon in IRC a while ago (though of course, we
forgot to bring it up at the proper time...).
Japser, can we get a new nib that has Command-Shift-T for Hide/Show toolbar and
Command-Shift-B for Hide/Show Bookmark Bar (that's what this bug is waiting on,
right)?
Created attachment 191096 [details]
MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

Fixes the key equivalents for Show/Hide Toolbar and Show/Hide Bookmarks Bar to
use shift instead of opt.

I couldn't figure out where the toggle state stuff hides, but changing the key
equivalents for the states visible in IB appears to fix this.  I.e., it works,
the menu still toggles the item name depending on the toolbar state, and
cmd-shift-letter both shows and hides the relevant toolbar.
Attachment #183631 - Attachment is obsolete: true
Attachment #191096 - Flags: review?(mozilla)
Comment on attachment 191096 [details]
MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

This is no longer any good since "Use Selection for Find" was added.
Attachment #191096 - Attachment is obsolete: true
Attachment #191096 - Flags: review?(mozilla)
Created attachment 192182 [details]
MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

Updated to current trunk MainMenu.nib.
Attachment #192182 - Flags: review?(mozilla)
(Reporter)

Comment 16

13 years ago
Comment on attachment 192182 [details]
MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

If that's all that's changed, then r=me.
Attachment #192182 - Flags: review?(mozilla) → review+
(Assignee)

Comment 17

13 years ago
i noticed xcode and mail dont' have key combos for hiding the toolbar. rather
than going with something non-standard (finder uses cmd-opt-t) what about
removing the shortcuts?
Created attachment 193123 [details]
New MainMenu.nib with no shortcuts for toolbar commands

(In reply to comment #17)
> i noticed xcode and mail dont' have key combos for hiding the toolbar. rather

> than going with something non-standard (finder uses cmd-opt-t) what about
> removing the shortcuts?

I don't really have a preference; I just thought this bug was a good, quick,
easy one to get fixed--and one I could actually do the nib-wrangling for :-)  

On one hand it is a bit strange to be removing keyboard shortcuts, but on the
other, showing/hiding various toolbars don't strike me as actions that users
would use frequently enough that a keyboard shortcut is imperative.  Plus,
users can easily add the shortcuts back if they wish (at least on 10.3 and
10.4), and it frees up two more shortcut combos to be used elsewhere if need be
(say a quick "bookmark this page" w/o dialogue or a "bookmark all tabs").

So here's a nib with the two shortcuts cleared, if that's the way we want to
go.
(In reply to comment #17)
> i noticed xcode and mail dont' have key combos for hiding the toolbar. rather
> than going with something non-standard (finder uses cmd-opt-t) what about
> removing the shortcuts?

A lot of people like the "hide/show toolbar" option. I don't think removing it
is the way to go. I also think we should keep it opt simply because the Finder
does this (albeit the Finder does *really* weird things on Panther and above
now...).

Anymore thoughts? This should be changed pre-1.0 anyway.
(Reporter)

Comment 20

13 years ago
(In reply to comment #19)
> I also think we should keep it opt simply because the Finder
> does this (albeit the Finder does *really* weird things on Panther and above
> now...).

The only reason I think it should be changed from using option is because "Hide
Toolbar" currently hides the toolbar on *every* window when the keyboard
shortcut is used, but it only hides the toolbar on the key window when it's
selected from the menu (as I said in comment 0).
(Assignee)

Comment 21

13 years ago
Comment on attachment 192182 [details]
MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

make sure the nib is up to date, and i'm ok with changing to shift.
Attachment #192182 - Flags: superreview?(pinkerton) → superreview+
Created attachment 195431 [details]
updated MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

Here's the Cmd-Shift- version of the nib again, based on 20050908 branch build
to account for the recent elipsis changes.  Not sure how to do all the "move
the reviews forward" magic in bugzilla....
Attachment #192182 - Attachment is obsolete: true
Attachment #193123 - Attachment is obsolete: true
Comment on attachment 195431 [details]
updated MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

Bump as a reminder this is waiting for checkin :-)
Comment on attachment 195431 [details]
updated MainMenu.nib with Cmd-Shift-T, Cmd-Shift-B

Reminder that this is waiting for checkin :-)

Comment 25

13 years ago
Fixed, trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.