Closed Bug 290522 Opened 19 years ago Closed 19 years ago

page scrolls in wrong direction (seamonkey/FF)

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.8beta2

People

(Reporter: Peter6, Assigned: bzbarsky)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050415
Firefox/1.0+

repro:
1.Open FF
2.Open testcase
3.scroll the page down by pressing a few times on the scrolldown button on the
vertical scrollbar
4.place the mouse just above the slider and click
5.the page scrolls down i/o up
6.press a few times on the scrollright button on the horizontal scrollbar
7.place the mouse just left of the slider and click
8.the page is scrolled right i/o left

testcase coming up
Attached file testcase
(In reply to comment #0)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050415
> Firefox/1.0+

> 4.place the mouse just above the slider and click
> 5.the page scrolls down i/o up

> 7.place the mouse just left of the slider and click
> 8.the page is scrolled right i/o left

Mouse position is invalidly reported in some cases on 2005-04-15 builds?
See Bug 290494 for Thunderbird case.
Keywords: regression
*** Bug 290607 has been marked as a duplicate of this bug. ***
*** Bug 290597 has been marked as a duplicate of this bug. ***
this regressed between 20050414 and 20050415.

related to Bug 290553 ?
Summary: page scrolls in wrong direction → page scrolls in wrong direction (seamonkey/FF)
Probably. All of these bugs certainly make the checkin for bug 289792 look very
suspicious. Anyone have a local tree they can back out that checkin from and see
what happens?
How can my bug (bug#290597) be a duplicate of this bug when my bug is older?!

>_<

This offends me as

-it's wrong
-I did search first
-I don't like reporting a duplicate
Oops, sorry for my stupidity. Apparently I got confused with the bug numbers,
and also took the "last updated" hours as reference.

My apologies.
Flags: blocking-aviary1.1?
Attached patch FixSplinter Review
This fixes all the problems I could find with scrollbars... it's really rather
a miracle this code ever worked before; getting the event->point from an
nsEvent that comes from a DOMEvent inside DOM event dispatch is not
particularly guaranteed to give you anything useful in _your_ coordinates....
Attachment #180983 - Flags: superreview?(roc)
Attachment #180983 - Flags: review?(roc)
Assignee: firefox → roc
Component: General → Layout: View Rendering
Flags: review?(roc)
Product: Firefox → Core
QA Contact: general → ian
Attachment #180983 - Flags: review?(roc)
Attachment #180983 - Flags: superreview?(roc)
Attachment #180983 - Flags: superreview+
Attachment #180983 - Flags: review?(roc)
Attachment #180983 - Flags: review+
Comment on attachment 180983 [details] [diff] [review]
Fix

Requesting approval for 1.8b2 for this regression fix.
Attachment #180983 - Flags: approval1.8b2?
Comment on attachment 180983 [details] [diff] [review]
Fix

a=brendan for 1.8b2.

/be
Attachment #180983 - Flags: approval1.8b2? → approval1.8b2+
Assignee: roc → bzbarsky
Fixed.
Status: NEW → RESOLVED
Closed: 19 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta2
*** Bug 290832 has been marked as a duplicate of this bug. ***
Did this fix cause bug 290921?
Flags: blocking-aviary1.1?
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: