Auto-Update should save installer to temporary location and delete on completion.

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
--
enhancement
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: M. LaPlante, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Currently as of FireFox 1.0.3, the auto update process for the browser works as
follows:  The update button is clicked, the new installer is downloaded to
Desktop in Windows, and the installer runs to completion.  The installer remains
on the desktop.
To me this makes no sense.  Auto-update operations are supposed to be
transparent as far as file downloading/executing/removal.  I believe this is the
precedent in most applications.  For example, Windows Update, Office Update, yum
(Fedora Linux), emerge (gentoo), portupgrade(FreeBSD), Apple Update (Mac), etc.
None of these retain the software downloaded after the installation is complete,
(except for temporary caches in some instances).  That's the whole point of
auto-update is to be transparent file-wise.  If a user wants to save the file,
they'll download and run it manually.  I propose the auto-update function should
save the installer to a standard temporary directory on the OS, and attempt to
remove the installer upon completion.
I think this is a matter of both convenience as well as good practice.  I've
seen many novice users with overloaded desktops because they simply don't bother
to clean it.  Leaving the executable like this is just contributing to system
pollution for the thousands of novice users in the world.

Reproducible: Always

Steps to Reproduce:
Putting it on the desktop was done intentionally, in the case that something may
go wrong with the update.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Putting it on the desktop was done intentionally, in the case that something may
> go wrong with the update.

Well what could go wrong that having the file on the desktop would fix?

And all the same, why does this prohibit us from deleting the installation file
after the installation completes.  If the installation completes isn't that
basically confirmation that nothing went wrong?

At the very least we could pop up a dialog offering to save or remove the file?  

I do understand what you mean, I just think there's a major precedent to the
contrary for a reason...I think its one of those things that hurts or annoys 10
people for every 1 it actually helps.  At least that's my impression...

Updated

13 years ago
Version: unspecified → 1.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050929
Firefox/1.4 ID:2005092901

WFM 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.