If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when the update RDF is unavailable Firefox reports update available and displays an empty listing

VERIFIED FIXED

Status

()

Toolkit
Application Update
VERIFIED FIXED
13 years ago
6 years ago

People

(Reporter: Chase Phillips, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
When the update RDF is unavailable Firefox reports there is an update available
and displays an empty listing.  I just hit this by chance while UMO admins were
doing server maintenance.  The RDF status went through two phases: missing and
server misconfiguration.  In both cases, Firefox displayed the wizard interface
and where when an update is present the "Firefox 1.0.X (en-US)" entry appears
instead a blank box was shown.

I'm under the impression that the expected result when the RDF is unavailable or
there is no stanza for the user's version is to infer that no updates are
available.  We should correct this behaviour for 1.0.3+ or 1.1.
*** Bug 302015 has been marked as a duplicate of this bug. ***
*** Bug 302068 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Flags: blocking1.8b4+
I don't think this is still an issue under the new update service. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Flags: blocking1.8b4+ → blocking1.8b4-
Resolution: --- → FIXED

Comment 4

12 years ago
That is correct. Update displays a brief message that no new updates are
available.  Verifying against recent trunk builds.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> That is correct. Update displays a brief message that no new updates are
> available.  Verifying against recent trunk builds.

Just curious, did you try changing app.update.url to a URL which references a
non-existent XML file?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.