onchange event handler not fired by arrow keys

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 126379
12 years ago
12 years ago

People

(Reporter: Joseph Myers, Unassigned)

Tracking

({testcase})

Trunk
PowerPC
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050331 Camino/0.8.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050331 Camino/0.8.3

Visit the page and try changing the select menu at the very bottom of the page
by using the mouse. When a different option is selected, the page is updated.


Reproducible: Always

Steps to Reproduce:
1. Visit the specified page.
2. Click on the select menu to put focus onto it.
3. Change the option by using the up/down arrow keys instead of the mouse.

Actual Results:  
The menu changes, of course, but the event handler is not fired until the
disappointed user gives up and removes focus from the select menu by clicking
elsewhere on the page. Then the user is surprised by unexpected navigation away
from the current page, which does not appear to be in response to his actions.

Expected Results:  
Instead of doing this, Camino should have triggered the onchange handler
immediately. This prevents the user from using the arrow keys to move to another
option, but this is fine because the user can use the mouse to drag and hold the
select menu until they reach any option that they would like to.

Comment 1

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.6) Gecko/20050331 Camino/0.8.3
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.6) Gecko/20050331 Camino/0.8.3
> 
> Visit the page and try changing the select menu at the very bottom of the page
> by using the mouse. When a different option is selected, the page is updated.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Visit the specified page.
> 2. Click on the select menu to put focus onto it.
> 3. Change the option by using the up/down arrow keys instead of the mouse.
> 
> Actual Results:  
> The menu changes, of course, but the event handler is not fired until the
> disappointed user gives up and removes focus from the select menu by clicking
> elsewhere on the page. Then the user is surprised by unexpected navigation away
> from the current page, which does not appear to be in response to his actions.
> 
> Expected Results:  
> Instead of doing this, Camino should have triggered the onchange handler
> immediately. This prevents the user from using the arrow keys to move to another
> option, but this is fine because the user can use the mouse to drag and hold the
> select menu until they reach any option that they would like to.

Cannot find the "Select" menu on this page. Please provide more info as to what
should be on this menu or where it is located. All I see are form submission
buttons, all of the rest are HTML links.

The bible quiz that this link refers to is using HTML form buttons for
submissions as far as I can see. I double checked and could not find any
pop-down menus.
(Reporter)

Comment 2

12 years ago
Sorry, the quiz from last week which allowed a verse to be selected each day 
has been removed.

I can reconstruct it, though, when I have time.

Since the page is not there anymore, I'm going to resolve this as WFM for now to
kick it off the UNCO list.  When you get the problematic page reconstructed, or
if you find another testcase/sample page, please *reopen* this bug.  Thanks.

Also, did onchange fire with the mouse?  (There's another UNCO about form menus
not updating, bug 268048)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

12 years ago
Here is a whole page to describe and recreate this bug:

http://www.codelib.net/home/jkm/2005/14.html

Thanks.
Status: RESOLVED → UNCONFIRMED
Component: HTML Form Controls → General
Product: Camino → Firefox
Resolution: WORKSFORME → ---
Is this bug 126379?
Assignee: pinkerton → events
Component: General → Event Handling
Keywords: testcase
Product: Firefox → Core
QA Contact: ian
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.