scroll bar takes a headstart to mouse when you start to scroll

RESOLVED DUPLICATE of bug 290522

Status

RESOLVED DUPLICATE of bug 290522
14 years ago
11 years ago

People

(Reporter: benoit, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8b2) Gecko/20050416
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8b2) Gecko/20050416

When you try to scroll a page using the scroll bar, when you start to scroll the
scroll bar suddenly jumps a little ahead of the mouse. If your mouse point is
close to the upper part of the scroll bar, this can even cause your pointer to
be on the 'empty' part of the main scroll element.

This happens on both the vertical and horizontal scroll bars.

For the vertical scroll bar, it always jumps down.
For the horizontal scroll bar, it always jumps to the right.

Reproducible: Always

Steps to Reproduce:
1. Load a page that triggers the browser's scroll bars.
2. Move the mouse pointer to one of the scroll bars.
3. Keep the mouse button down.
4. Move the mouse one instance to either direction.

Actual Results:  
The scroll bar will jump further than how much you intended to scroll.

Expected Results:  
The scroll bar movement should have been consistent with the mouse movement.
(Reporter)

Updated

14 years ago
Keywords: regression
OS: other → Windows 95

Comment 1

14 years ago
I mentioned this in bug 290553#c8. This was happening in build 20050415 and it
is happening in 1.8b2 build 2005041606 under XP Pro SP2.
We need to determine if there is a duplicate bug.

adding clean-report keyword 
Keywords: clean-report

*** This bug has been marked as a duplicate of 290522 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.