Installer does not check for previous installations

VERIFIED DUPLICATE of bug 247884

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 247884
13 years ago
12 years ago

People

(Reporter: barryjj, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When trying to upgrade releases, the upgrade utility seems to download and run
the new installer.  While this is great, the installer doesn't check for
previous installations -- it seems to just overwrite the previous release.  This
leads to unused registry entries and invalid Add/Remove Program entries.  Trying
to uninstall an older version only leads to uninstalling the current version.

Reproducible: Always

Steps to Reproduce:
1. Install backlevel version of firefox.
2. Download new code and run install or use the upgrade check utility.
3. Run as normal.  Add/Remove Programs now has the backlevel and current level
of Firefox listed.  Removing one causes Firefox to be removed completely.

Actual Results:  
Described above.

Expected Results:  
Installer should check for previous versions and uninstall them before
continuing the install/upgrade.

*** This bug has been marked as a duplicate of 247884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.