Update button in Extensions window should be disabled when list is empty

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Christian Schmidt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla1.8final
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

13 years ago
Steps to reproduce:
1. Launch a new Firefox installl with no extensions installed
2. Open the Extensions window using Tools > Extensions

Actual results:
The Update button is enabled.

Expected results:
The Update button should be disabled, because there is nothing to update.

... or what? It looks as if something is happening, but I don't know what that is.

A friend of mine thought that the way to install extensions was to go to the
extension window, press Update and wait for a list of available extensions.
(Reporter)

Comment 1

13 years ago
Created attachment 180929 [details] [diff] [review]
Disable the Update button when there are no extensions in the list
[Checked in: Comment 4]
Attachment #180929 - Flags: review?(bugs)

Updated

13 years ago
OS: Linux → All
Hardware: PC → All
(Reporter)

Updated

13 years ago
Attachment #180929 - Flags: review?(bugs) → review?(mconnor)

Comment 2

13 years ago
*** Bug 294198 has been marked as a duplicate of this bug. ***
Comment on attachment 180929 [details] [diff] [review]
Disable the Update button when there are no extensions in the list
[Checked in: Comment 4]

r=me, assuming this isn't bitrotted on trunk with the massive EM whackage.
Attachment #180929 - Flags: review?(mconnor) → review+
(Reporter)

Updated

13 years ago
Attachment #180929 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #180929 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
fix checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Attachment #180929 - Attachment description: Disable the Update button when there are no extensions in the list → Disable the Update button when there are no extensions in the list [Checked in: Comment 4]
Attachment #180929 - Attachment is obsolete: true
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.