directory index is called (silently) after request of other page

VERIFIED INVALID

Status

()

Core
Networking: HTTP
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: mozilla, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6) Gecko/20050226 Firefox/1.0.1

When I open the page http://anyurl.any/anything.php firefox always calls
http://anyurl.any/ or http://anyurl.any/index.php (i dont know which one but i
think it is http://anyurl.any/ = directory index) after ~200 miliseconds. The
Page is requested by the browser (which can be easily proofed by php code which
is executed) but will not appear! Why does firefox request the directory index?

Reproducible: Always

Steps to Reproduce:
1. call http://firefox.suavemente.de/bug.php
2. Refresh after few seconds
3. Look the table

Actual Results:  
You can see that ~200 miliseconds after /bug.php was called (and insertet actual
time into database) /index.php was called (and also insertet something into
database to proof that it was called)

Expected Results:  
Of couse /index.php shoud not be rtequestet. Only /bug.php

Source of my php example (both bug.php and index.php):

<?php

	$db = mysql_connect("localhost", "webXXX","XXXXXXXX");
  mysql_select_db("usr_webXXX_1",$db);

	$sql = "INSERT INTO `firefox` (`from`,`microtime`) VALUES ('"
.$_SERVER['PHP_SELF'] ."','" .microtime() ."')";
	echo "<br /><br /><br /><b>SQL:</b> <code>$sql</code><br /><br /><br /><br />";
	mysql_query($sql);
	
	echo "<table><tr><th>id</th><th>page</th><th>microtime</th></tr>";
	$result = mysql_query("SELECT * FROM `firefox` WHERE 1 ORDER BY `id` DESC");
	while ($myrow = mysql_fetch_array($result))
	{
	  echo "<tr><td>" .$myrow['id'] ."</td><td>" .$myrow['from'] ."</td><td>"
.$myrow['microtime'] ."</td></tr>";
	}
	echo "</table>";
	  

?>
This is wfm with  Mozilla/5.0 (Windows; U; Windows NT 5.2; de-DE; rv:1.8b2)
Gecko/20050414
hmm, but I can reproduce this with FF1.0.3 and a nightly FF trunk build.
-> networking to find out where this index.php comes from
Assignee: firefox → darin
Status: UNCONFIRMED → NEW
Component: General → Networking: HTTP
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → Trunk
(Reporter)

Comment 3

13 years ago
Maybe it has something to do with bug 247913 ???
So... I can't reproduce this in a debug Firefox build on that page.  But I think
that's because the part of the page below the SQL insert statement just never
gets changed (the new insert seems to be ignored)?

Is there a reasonable testcase actually showing the bug?

Note that an HTTP log shows Firefox on Linux just requesting /bug.php and
/favicon.ico
Flags: blocking1.8b3?
The testcase seems to be broken (doesn't add new entrys)
Reporter: Can you fix that ?

You can see the loading from index.php around #50 on that bug and that's from me.
(Reporter)

Comment 6

13 years ago
Fixed! Now i put a link to empty the table when it is "full" (128 entries)
OK.  So I _do_ see the bug (in that the index.php appears in the table), but
Firefox is NOT making that request (verified via HTTP logging).

Does you server call index.php for the /favicon.ico request or something?
Ah, yes.  Loading http://firefox.suavemente.de/favicon.ico directly adds
index.php to the table over and over again.  So it's just a server bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

13 years ago
But I did not have that bug using IE
true but IE doesn't ask for the favicon unless you bookmark the page.

verified invalid (I suck: i should have catched that favicon loading)
Status: RESOLVED → VERIFIED

Updated

13 years ago
Flags: blocking1.8b3?
You need to log in before you can comment on or make changes to this bug.