Adobe Reader 7.0 Plugin(Linux) Crashes Firefox (and Mozilla)

RESOLVED WORKSFORME

Status

Plugins Graveyard
PDF (Adobe)
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: Thomas Ronayne, Unassigned)

Tracking

({stackwanted})

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

With the Adobe Reader 7.0 Plugin installed, any attempt to open any PDF file
(from a web page or a file) crashes Firefox (and Mozilla).

The error message is:
*** glibc detected *** free(): invalid next size (fast): 0x090fd8a0 ***
/usr/local/firefox/run-mozilla.sh: line 159:  5398 Killed                 
"$prog" ${1+"$@"}

Removing nppdf.so from the <path>/firefox/plugins directory and forcing Firefox
to open <path>/acroread as a helper application (executing acroread) appears to
work all right.


Reproducible: Always
Pleas eprovide a Talkback ID from that crash
Assignee: bugs → nobody
Component: File Handling → Plug-ins
Product: Firefox → Core
QA Contact: aebrahim-bmo → plugins
Version: unspecified → 1.7 Branch

Comment 2

13 years ago
FWIW, I loaded
http://www.ir-group.com/newsletter/pdf/issue3.pdf
in Firefox 1.0.3 rv: 1.7.7 (under XP Pro SP2 though) and Acrobat Reader 7.0.0
2004-12-14 loaded the document in FF and I did not crash.
I upgraded to Acrobat Reader 7.0.1 and did not crash.

adding stackwanted keyword
Keywords: stackwanted
(Reporter)

Comment 3

13 years ago
Reference Talkback ID (1): Glad to, tell me how -- I have to kill the browser
process to get out of it.

Reference (2): This problem is in Linux -- whether it works properly in XP is
not particularly relevant. Both kernels 2.4.29 and 2.6.10 produce the same
result in (separate installations of Slackware 10.1). I did use the beta
software during the testing period, by the way, and it did not exhibit this
problem (others, yes, but not this). Reader 7.0 works fine stand-alone and
appears to work as a helper application; when invoked as a plugin it freezes the
browser (both Mozilla suite and Firefox) and the browser has to be killed. I
have gone back to Acrobat Reader 5.0.10 plugin and it works just fine (as it
always has). And, before anybody asks, yes, I completely removed Acrobat Reader
5 and Acrobat Reader 7 (from /usr/local), all .acrobat and .adobe directories
and nppdf.so from the system while testing both installations. I always copy
nppdf.so to the <mozilla>/plugins directory, logged in as root and start the
browser as root prior to any additional testing. The Acrobat 5 plugin works, the
Reader 7 plugin does not and I have to kill the browser to get out of 7.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

12 years ago
Used the 1.5 Beta of FF and could reproduce the bug. Though, FF is not craching
but, as the 1.1 version before, simply shows a blank page instead of the pdf.

Found following solution: The plugins in /usr/lib/mozilla/plugins seem to have
some higher preference then a local plugins folder ~/.mozilla/plugins. The old
version of nppdf.so in the former collides with the new and local 7.0 version.
The first has to be removed for running the new plugin. That is propably not,
what was intended.
Blocks: 336184
Summary: Adobe Reader 7.0 Plugin Crashes Firefox (and Mozilla) → Adobe Reader 7.0 Plugin(Linux) Crashes Firefox (and Mozilla)

Comment 6

11 years ago
sounds like duplicate of bug 244460.
does this match bug 244460?
(Reporter)

Comment 7

11 years ago
Original report from 2004.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-reader
Version: 1.7 Branch → unspecified
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.