Context menus go off-screen when their height is more than half the screen height.

VERIFIED DUPLICATE of bug 245163

Status

()

VERIFIED DUPLICATE of bug 245163
14 years ago
12 years ago

People

(Reporter: r123456789, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When rightclicking, the first few items of the context menu that appears (back,
forward,reload,...,save link as,... - the menu with these items) are not
visible, if you click "somewhere around the middle". More accurately:
If the context menu would have dropped below the bottom half of the screen (i.e.
screenheight - cursor-Y position < context menu height) it flips it to the
top-half of the screen (i.e. the bottom of the menu is now where the cursor is,
instead of the top). Now, because of either a low screen resolution, or added
context menu items this means that if the menu is longer than 50% of the screen
height the top of the menu flies off the top of the screen, if you click in an
area that is lower than [screen height - context menu height] but higher then
the [context menu height].

Reproducible: Always

Steps to Reproduce:
1.Decrease resolution or add more context menu items
2.Rightclick somewhere near 50% of screenheight
3.If context menu appears below cursor, go back to step 1, else try to point at
the first item (usually "back" in the context menu).

Actual Results:  
First couple of menu items can't be reached with the mouse (but if you know
where to go you can reach them blind with the keyboard).

Expected Results:  
Not pass the top of the screen, but stick the menu against the top of the
screen, and go as far as possible down. If [menu height > screen height] add a
scroll arrow to the bottom of the list (onscreen preferably...j/k) and once that
one is "activated", add one to the top, if the bottom of the list is reached,
remove the bottom arrow. If the top of the list is reached, remove the top arrow
(activating either arrow re-enables the other one).

The theme has an influence (text height, borders,...), but even the default
theme does this for me.

1024*768 screen resolution was used.

*** This bug has been marked as a duplicate of 245163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
Created attachment 180945 [details]
example screenshot

Here you can see what happens : the back, forward and reload options cannot be
reached by mouse.

(Also you can see that there is a strange blank space in the context menu, you
can select them (it's about 5 tiny selectable blocks), but I have no idea where
they came from and wish to get rid of them, but can't figure out how).
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.