Closed Bug 290743 Opened 15 years ago Closed 13 years ago

This display:-moz-grid testcase freezes Mozilla

Categories

(Core :: Layout, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

References

Details

(4 keywords)

Attachments

(1 file)

the testcase that I'll attach freezes Mozilla. I get 100% cpu and Mozilla
becomes unusable. I'm using the 2005-04-16 trunk build.
Basically the testcase consists of this:
<body style="display:-moz-grid;">
<input type="radio"><input type="radio">
</body>

Also, moz-deck, moz-inline-grid and so are hanging Mozilla with this.
Hmm... I can't reproduce this on Linux....
Still hangs with 2006-04-10 trunk build.
Can you try breakpointing and seeing where we're spinning?
I can't seem to interrupt gdb under mingw. Ctrl-C doesn't work here.
WFM using a Mac trunk nightly from a few days ago.
Severity: normal → critical
Confirmed on:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/2006101023 Firefox/2.0

Hangs for about 5 minutes using full CPU then returns to normal.
Also hangs on:

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/2006110904 Minefield/3.0a1

Although for only about 3 minutes.
Still worksforme on Linux.  Someone on Windows will need to do some debugging here....
Ok, I can see the issue in a 2006-12-06 build, but not anymore in a 2006-12-10 build, most likely fixed by the reflow branch landing.
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: reflow-refactor
Flags: in-testsuite?
Resolution: --- → FIXED
Confirming it now WFM.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061211 Minefield/3.0a1 ID:2006121108 [cairo]
You need to log in before you can comment on or make changes to this bug.