Add the (administrative) ability to transition flags from one flagtype to another

UNCONFIRMED
Unassigned

Status

()

Bugzilla
Attachments & Requests
--
enhancement
UNCONFIRMED
13 years ago
9 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
It's possible for me to search for all "Webtools:Bugzilla" bugs and move them to
"Bugzilla:General", but it isn't possible for me to search for all "review"
flags (in NSPR product) and move them to "first-review" (in NSPR product).

Normally this isn't needed by non empowered users, however as it happens, when
people move bugs across products they tend to need something similar to this, so
including code to allow less empowered users to do similar changes should be
considered.

Comment 1

13 years ago
see also the initial discussion in bug 261995.


*** This bug has been marked as a duplicate of 274802 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
I don't think this is a dupe, since bug 274802 is about preserving flags when
moving bugs between products, while this bug is about migrating flags from one
type to another while keeping bugs in the same product.

In theory this is a simple SQL query, something like:

UPDATE flags JOIN bugs ON flags.bug_id = bugs.bugid SET flags.type_id = XXX
WHERE  flags.type_id = YYY and bugs.product_id = ZZZ

Or two queries, if you want to move flags for an arbitrary set of bugs.  One
would need to consider the effects of moving to a differently configured flag,
however.  If you move from a multiplicable flag type to a non-multiplicable
type, what do you do with multiple flags on a single bug/attachment? 
(Presumably, you leave them multiple, but don't permit future multiplications,
as we do when changing the configuration of a type from multiplicable to
non-multiplicable).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
OS: Windows XP → All
Hardware: PC → All

Updated

9 years ago
Duplicate of this bug: 343853
You need to log in before you can comment on or make changes to this bug.