copy/paste URL in Location Bar places formatted text in MS Word

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Simson Garfinkel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

copy of URL in address bar places Text AND HTML onto the pasteboard. This is
really annoying when you want to copy a URL and then paste it into Microsoft
Word or something. What gets pasted is HTML, which then needs to be reformatted.

Reproducible: Always

Steps to Reproduce:
1.Copy the URL in the address bar. 
2.Paste it into Microsoft Word.



Actual Results:  
Yuck. Notice that it pastes in a large, sans-serrif font. 
3.

Expected Results:  
It should paste without any font attributes.

It happens with other word processors beyond Microsoft Word.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 2

13 years ago
reporter (Simson), can you check if this is done by Word's autoformat feature?
Summary: copy of URL in address bar places Text AND HTML onto the pasteboard → copy/paste URL in Location Bar places formatted text in MS Word

Comment 3

13 years ago
Comment:

This can besesolved by installing the extension:

Copy Plain text 0.3.1

Downloadable on the Firefox Page (or try a google search)


Cheers,

g
(Reporter)

Comment 4

13 years ago
It's great to know that there is an extension to fix this bug. However, this is a bug and I would recommend 
actually fixing the code base in a future release.

Thanks!
Assignee: bross2 → nobody
This works for me using Firefox 2.0.0.3 on Mac OS X 10.4.9 and Microsoft Word 2004. Simson, if you're able to reproduce using Firefox 2.0.0.3 with a clean profile, and can confirm that this is, indeed, not Word's autoformat feature, please comment and reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

11 years ago
Hi. I just confirmed that this bug is still present in 2.0.0.3. 

Specifically, the Firefox address bar, when you copy text, is putting both plain text and rich text on the pasteboard. It should only put plain text on the pasteboard. Apparently there is an extension that fixes this problem. However, it's wrong to require Firefox users to download an extension to overcome a bugfix. 

You can demonstrate this problem by creating a Word document on the Mac, making all of the text itallic, copying a URL from the address bar, and pasting it into the itallic text. If the text being pasted was plain, then the pasted text would pick up the Italic font from the surrounding text. But it pastes in as roman, not itallic, because the version on the pasteboard has font information.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Simson, thanks for reporting back. I see this as well using Firefox 2.0.0.3 given the steps you gave. I also tested using the latest trunk nightly and noticed that the problem appears to be fixed. Can you confirm that the steps below work correctly using the latest trunk nightly?

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Steps to reproduce:
1. Create a new document (a line of text or so) in MS Word/Mac
2. Make all the text in the document italic
3. Copy the URL from the location bar of Firefox
4. Paste the URL into the middle of the line of text in MS Word

Pasted text should be italic and formatted the same as the rest of the document.
(Reporter)

Comment 8

11 years ago
Yes, the problem is fixed in the latest trunk. THanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Resolving as works for me since we aren't sure exactly what fixed this (probably the change to cocoa widgets).
Resolution: FIXED → WORKSFORME
Duplicate of this bug: 298763
You need to log in before you can comment on or make changes to this bug.