firefox interprets text/plain that is 95% not binary as binary

VERIFIED INVALID

Status

()

Firefox
File Handling
VERIFIED INVALID
13 years ago
3 years ago

People

(Reporter: martin f. krafft, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050306 Firefox/1.0.1 (Debian package 1.0.1-2)

The returned page (which is reproduced with a simple CGI) specified content-type
text/plain. Nevertheless, Firefox insists on it being a BIN file and only offers
to download it.

PS: text/* should just render inline.

Reproducible: Always

Steps to Reproduce:
Visit http://albatross.madduck.net/cgi-bin/firefox-bug.cgi
Actual Results:  
BIN file download

Expected Results:  
inline text display
(Reporter)

Comment 1

13 years ago
I just noticed the line

                             _signature = 4]¾I³Ó<89>úÄë<99>ÁõÆ­

which causes Firefox to revert to binary. I guess this is fundamentally correct,
but I don't think Firefox should make the decision. In this case, the web server
is broken, so Firefox should just follow the suggestion of text/plain.

Comment 2

13 years ago
According to bug 220807, files sent as "text/plain" but containing invalid
characters deliberately bring up the "What should FF do ..." dialog. 

As the behaviour is by design, I think this bug is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Summary: firefox interprets text/plain as BIN file → firefox interprets text/plain that is 95% not binary as binary
Verified.  The server in question is one known to be buggy and send arbitrary
data whose type it doesn't actually know as text/plain, so we really can't trust
it (especially since the developers of the server have indicated they have no
plans to fix this bug).
Status: RESOLVED → VERIFIED
Duplicate of this bug: 509840
You need to log in before you can comment on or make changes to this bug.