Closed Bug 29085 Opened 20 years ago Closed 20 years ago

ESC doesn't stop browser loading page

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P1)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: ken.horn, Assigned: mcafee)

References

(Blocks 1 open bug)

Details

(Whiteboard: [nsbeta2-][nsbeta3+])

When a page is loading, pressing the escape key should cancel the request. Doesn't.
4x does this.  Reassign to german.
Assignee: cbegle → german
Status: UNCONFIRMED → NEW
Component: Browser-General → User Interface: Design Feedback
Ever confirmed: true
Keywords: 4xp
QA Contact: asadotzler → elig
*** Bug 32805 has been marked as a duplicate of this bug. ***
*** Bug 32805 has been marked as a duplicate of this bug. ***
QA Assigning non-confidential New/Assigned User Interface: Design Feedback bugs 
to Matthew Thomas (mpt@mailandnews.com).

Matthew Thomas is now the QA owner for the User Interface: Design Feedback 
component. (Bugs that involve UI issues in the Netscape-branded Mozilla browser 
should continue be QA assigned to elig@netscape.com.)
QA Contact: elig → mpt
This should work on all OSes, even though it didn't in 4.x. That is, on MacOS Esc 
should work too (in addition to Ctrl+.). --> All/All.
OS: other → All
Hardware: PC → All
Summary: ESC doesn't stop browser loading page, must hit STOP icon → ESC doesn't stop browser loading page
"Esc" should stop page loading like 4.x.  Pleare reassign to correct engineer to 
be implemented.
Assignee: german → don
Reassigning as per Don
Assignee: don → mcafee
Keywords: nsbeta2
Target Milestone: --- → M17
Putting on [nsbeta2-] radar. Not critical to beta2.  Putting on nsbeta3 keyword.
Keywords: nsbeta3
Whiteboard: [nsbeta2-]
Move to M20 target milestone.
Target Milestone: M17 → M20
nav triage team:
nsbeta3-
Unless this is a accessabilty requirement, this is not needed.
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
nav triage team:
actually, we rethought, think it is accessability, so nsbeta3+
Whiteboard: [nsbeta2-][nsbeta3-] → [nsbeta2-][nsbeta3+]
--> Keyboard Navigation
Blocks: uaag
Component: User Interface: Design Feedback → Keyboard Navigation
QA Contact: mpt → sairuh
*** Bug 47992 has been marked as a duplicate of this bug. ***
fixed on windows...other platforms?
well, this is looking fine using opt comm bits 2000.08.14.12 [rh 6.2 linux].
mcafee, didja [or, someone else?] checkin a fix?

feel free to resolve this.
Priority: P3 → P1
Resolved, then.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
...and vrfy fixed using 2000.08.16.xx bits.
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.