Mozilla Firefox is not responding to Synaptics Touchpad Virtual Scrolling

RESOLVED DUPLICATE of bug 20618

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 20618
13 years ago
13 years ago

People

(Reporter: Matthew Bell, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Firefox UI does not respond to Virtual Scrolling events from the Synaptics
Touchpad driver. This may be a Toolkit issue. This is bug 146962, I think, but I
can't reopen it - user to bugzilla interface failure, sorry.

Reproducible: Always

Steps to Reproduce:
1. Enable Virtual Scrolling in SynTP preferences.
2. Perform Virtual Scrolling action, as signified by mouse cursor change.
3. Firefox does not scroll, other application do.

Actual Results:  
The Virtual Scrolling mouse cursor appears, but no scrolling occurs.

Expected Results:  
Scrolling shoudl have occured

This bug occurs for me in v. 7.12 and v. 5.8 of the Synaptics Touchpad Software.
The scrolling process works, however, in v. 7.5 of the software. The fix listed
in the aforementioned realted bug is present in both 7.x versions, and does not
make the Virtual Scrolling in v. 7.12 work for me.
I will be happy to test code and try to provide debugging output for you; this
may also just be an issue with the Synaptics driver and collaboration with
<support@synaptics.com> may be needed...

Comment 1

13 years ago
Related to bug 20618 (or one of its many duplicates like bug 281346) and/or bug
250989?
Summary: Mozilla Firefox is not responding to Synaptics Touchpad Virtual Scrolling → Mozilla Firefox is not responding to Synaptics Touchpad Virtual Scrolling
(Reporter)

Comment 2

13 years ago
Yeah, it's the same bug as mentioned in the comments of those bugs; doh! I did
search first, I promise. Just to reiterate, the fix mentioned in bug 146962
seems to be wrong.

*** This bug has been marked as a duplicate of 20618 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.