Last Comment Bug 290869 - Request for registering the malayalam version of Mozilla Firefox
: Request for registering the malayalam version of Mozilla Firefox
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
: 287434 293667 (view as bug list)
Depends on:
Blocks: 299538
  Show dependency treegraph
 
Reported: 2005-04-18 14:15 PDT by Joyce K Babu
Modified: 2014-03-07 04:12 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
The xpi file (158.32 KB, application/x-xpinstall)
2005-05-12 16:57 PDT, Joyce K Babu
no flags Details
The zipped localization directory (194.02 KB, application/x-zip-compressed)
2005-05-12 17:03 PDT, Joyce K Babu
no flags Details

Description Joyce K Babu 2005-04-18 14:15:03 PDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; en) Opera 8.00
Build Identifier: 

I would like to register the localization of firefox to malayalam. I have 
completed the translation work. The details are
Names : Joyce K. Babu, Joshy K. Jacob, Sijo George, Jijo Raj
Email :joycekbabu@gmail.com, joshyk@gmail.com, sijogeorge@myaddress.co.nz, 
jijoraj@myaddress.co.nz
Code : ml-IN

awaiting your early reply
Joyce K. Babu

website : http://www.prokerala.com/


Reproducible: Always
Comment 1 Martin Creutziger [:MMx] 2005-04-18 21:58:30 PDT
*** Bug 287434 has been marked as a duplicate of this bug. ***
Comment 2 Martin Creutziger [:MMx] 2005-04-18 22:01:18 PDT
Please do not file duplicate bugs. (duped the older one as this one has more
details)
As we don't accept new languages for the Firefox 1.0.x series any more, please
work on the trunk.
You find information about that on the mozilla.org website and in the newsgroup
netscape.public.mozilla.l10n
Comment 3 Martin Creutziger [:MMx] 2005-05-10 14:23:51 PDT
*** Bug 293667 has been marked as a duplicate of this bug. ***
Comment 4 Zibi Braniecki [:gandalf][:zibi] 2005-05-10 18:01:11 PDT
The very first step to get your account is to attach to this bug zipped
directory with your localization of Firefox 1.0.x. It must have the directory
structure we're using for Firefox 1.0.x translation. I will review this.
Comment 5 Joyce K Babu 2005-05-12 16:57:32 PDT
Created attachment 183453 [details]
The xpi file
Comment 6 Joyce K Babu 2005-05-12 17:03:56 PDT
Created attachment 183454 [details]
The zipped localization directory
Comment 7 Joyce K Babu 2005-05-12 17:09:54 PDT
Thankyou for the reply and help. I have created an ml-IN.xpi and it works fine
on my computer. In Windows 98, due to the poor support for unicode, I am having
a problem withe the display. In Xp it works fine. I have attached the xpi file
and the zipped localization directory.

Thankyou very much

Joyce K. Babu
Comment 8 Pavel Franc - Mozilla.cz 2005-05-19 03:17:13 PDT
There is also one registration bug for Malay - bug 286080. Is Malay the same
language ?
Comment 9 Pavel Franc - Mozilla.cz 2005-05-19 04:05:07 PDT
(In reply to comment #8)
> There is also one registration bug for Malay - bug 286080. Is Malay the same
> language ?

So, I was informed that it isn't. Sorry for bugspam.
Comment 10 Joyce K Babu 2005-05-20 11:44:00 PDT
I think Malay is the language of Malayasia. Our request was for MALAYALAM (ml-
IN), a language spoken by over 35 million people in south India.
Thankyou
Comment 11 Joyce K Babu 2005-06-11 13:19:20 PDT
Why is there is no response for so long ? How do we know if our request is 
accepted, rejected or is under processing ? 
Please reply 

Joyce
Comment 12 Pavel Franc - Mozilla.cz 2005-06-12 15:03:40 PDT
> Why is there is no response for so long ?
Because there are so many things to take care about but only few people to
handle it and most of them are bussy all the time :(

> How do we know if our request is accepted, rejected or is under processing ? 
Since there is no other ml-IN registration request and you have provided the
ml-IN files, you are technicaly taken as a ml-IN l10n team. There is no official
l10n team page but we track these issues at our wiki page [1].

The next step is to prepare your locales files in CVS structure form - either
for Firefox 1.0 [2] or better for Firefox 1.1 [3], and commit them to the
Mozilla.org CVS server [4]. Therefore, at least one of your l10n team
member should have a CVS account. To get CVS account you need to fill a new bug
and provide ssh public key [5], send the form [6] and attach/link your files in
CVS structure form - see bug 263726 as an example.

1] http://wiki.mozilla.org/L10n:Localization_Teams
2] http://www.mozilla.org/projects/firefox/l10n/
3] http://wiki.mozilla.org/Firefox:1.1_Localization
4] http://lxr.mozilla.org/l10n/source/ (for Firefox 1.1)
5] http://www.mozilla.org/cvs-ssh-faq.html#s2
6] http://www.mozilla.org/hacking/form.html
Comment 13 Axel Hecht 2005-08-15 07:20:37 PDT
Comment on attachment 183454 [details]
The zipped localization directory

Ooops, sorry. This answer should have come much sooner.

We need a source localization, in the same structure as the, say, pl locale,
http://lxr.mozilla.org/l10n/source/pl.
Comment 14 Joyce K Babu 2005-08-27 12:40:04 PDT
Can you plz tell me how to download this directory structure.
Comment 15 Axel Hecht 2005-09-07 06:13:19 PDT
Oops, this one dropped in my inbox again,

http://wiki.mozilla.org/Firefox:1.1_Localization has instructions on how to 
check out locales from CVS.
Comment 16 Joyce K Babu 2005-09-11 10:52:21 PDT
           please check http://www.prokerala.com/mozilla/pl.zip

Is this the correct directory structure? it has been downloaded from
cvs-mirror.mozilla.org:/l10n co l10n/pl..
Comment 17 Axel Hecht [pto-Aug-30][:Pike] 2005-09-12 01:44:43 PDT
(In reply to comment #16)
> it has been downloaded from
> cvs-mirror.mozilla.org:/l10n co l10n/pl..

if so, then yes.
Comment 18 Joyce K Babu 2005-10-21 08:18:47 PDT
The new localization files are uploaded at
http://prokerala.com/mozilla/ml-IN.zip . Please review the files. The base files
were downloaded from :pserver:anonymous@cvs-mirror.mozilla.org:/l10n co l10n/en-GB
Comment 19 Pavel Franc - Mozilla.cz 2005-10-30 17:20:08 PST
The archive ml-IN.zip contains IMO only English strings. I din't find anything to review.
Comment 20 Joyce K Babu 2005-11-06 01:23:16 PST
I have just translated 300 strings since I wanted to make sure that this was the correct structure. Can I continue translating? Plz reply
Comment 21 Axel Hecht [pto-Aug-30][:Pike] 2005-11-07 13:21:18 PST
(In reply to comment #20)
> I have just translated 300 strings since I wanted to make sure that this was
> the correct structure. Can I continue translating? Plz reply
> 

The directory structure looks ok. I hope you actually focus on firefox for now,
and don't get messed up with the thunderbird parts in en-GB, like mail or editor.
Comment 22 Praveen A 2007-01-30 05:24:40 PST
Its been about 14 months since the last comment appeared here and there  seem to be no interest to continue the translations by the initial contributor (Didn't get any response for my query as well). I would like to take over as the owner of firefox malayalam translations. I am currently the malayalam coordinator for debian installer. You can see my contributions here http://bugs.debian.org/cgi-bin/pkgreport.cgi?which=submitter&data=pravi.a%40gmail.com&archive=no&version=&dist=unstable.

Cheers
Praveen 
Comment 23 Praveen A 2007-01-31 22:46:27 PST
Hi,

 I got a reply from Joyce today and I will work with him to get the project moving.

Cheers
Praveen
Comment 24 Axel Hecht [pto-Aug-30][:Pike] 2007-02-19 10:36:09 PST
Ok, this made progress over the cvs account bug 299538, closing this one out.

Please add information about your team to http://wiki.mozilla.org/L10n:Teams:ml, similar to what I did for http://wiki.mozilla.org/L10n:Teams:de.

Filed bug 370916 for the bugzilla component request.
Comment 25 Axel Hecht [pto-Aug-30][:Pike] 2007-05-18 08:04:19 PDT
Setting up dependencies for the cvs account bug.

Note You need to log in before you can comment on or make changes to this bug.