sidebar "add bookmark" window appears twice when launched from webpage, causes memory leak in Xwindows

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: tom, Unassigned)

Tracking

({qawanted})

Trunk
x86
All
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression?, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417 Firefox/1.0+

When clicking 'news sidebar panel' from the URL, I get the "Add Bookmark" link
twice.  Reportedly this doesn't occur in 1.0.3, but occurs in a Firefox Aviary
1.0.1 nightly.  It also occurs in my trunk copy.

Reproducible: Always

Steps to Reproduce:
1. Go to URI (MozillaNews.org/toys.php)
2. Click 'news sidebar panel'
3. Hit cancel
4. Hit cancel

Actual Results:  
Two add bookmark windows

Expected Results:  
One add bookmark window

The first time I clicked, I got one really big (fullscreen, almost) add bookmark
window in the background and a normal sized one, centered in the big one, in the
foreground.  Closing these two and then clicking the 'news sidebar panel' link
again caused two, normal sized add bookmark popups in the top-left of the browser.

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050417
Firefox/1.0+

I can reproduce this.  The first time around, it spawns one rather large add
bookmark dialog, and a normal sized one on top.  The second time around, it has
two normal sized dialogs, one on top of the other.  It appears to be caused by a
regression of some sort for something that got checked into both aviary and
trunk, since it doesn't happen on the 1.0.3 milestone.  I am going to go ahead
and confirm this, and add the qawanted keyword to see if somebody can come up
with a testcase.  I may bug jX, since it's his site that we reproduce the bug on
anyway. Adding regression? to the status whiteboard, I will see if I can't track
it down.  It appears to be something that has occured since April 16th.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Whiteboard: regression?

Comment 2

13 years ago
Ok, I'm seeing this too, the fullscreen thing too. It's not us, I checked that
we no longer use the old hackish JS we used years back.
linux trunk firefox 20050418, that link gives me a large grey fx window and X
grows to over a gigabyte, which is annoying.
OS: Windows XP → All

Comment 4

13 years ago
Created attachment 181115 [details]
Relevant snippet off that URL

(In reply to comment #2)
> Ok, I'm seeing this too, the fullscreen thing too. It's not us, I checked
that
> we no longer use the old hackish JS we used years back.
>
I can't think of anything that could be causing this other than the
rel="sidebar" portion of the link, since you are just using markup to do it
now.
 I am going to go ahead and make an attachment of the relevant portion of the
markup.

Comment 5

13 years ago
(In reply to comment #4)
> Created an attachment (id=181115) [edit]
> Relevant snippet off that URL
> 
And it appears that you can't reproduce this using that snippet... crap.

(Reporter)

Comment 6

13 years ago
Changing summary now that new information has appeared,
changing target to Future (since this is trunk and it should be fixed),
changing severity to critical (linux memory leak),
added ? for blocking-aviary 1.1 because of the severity on linux.
Severity: trivial → critical
Summary: Add Bookmark window appears Twice when launched from webpage → sidebar "add bookmark" window appears twice when launched from webpage, causes memory leak in Xwindows
Version: unspecified → Trunk
(Reporter)

Comment 7

13 years ago
Sorry for the bugspam, nix on that 'target future', i was hammering the system
to try to figure out which things that the "submitter" could change, but really
couldn't.  I removed first the priority change (that was fine) and then the
target change, but forgot to remove the change in the comments.

Again, sorry.

Comment 8

13 years ago
This is still broken on FC3 for the current release; clicking on the "news
sidebar panel" causes the browser to crash immediately.

Build ID:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513
Fedora/1.0.4-1.3.1 Firefox/1.0.4

*However*, the behavior is correct (a single 'Add Bookmarks' window appears, no
crash) when using a current trunk build.

Build ID:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050623 Firefox/1.0+
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
this is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020708 Firefox/3.0.0.0 ID:2008020708
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Component: Bookmarks → Places
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
You need to log in before you can comment on or make changes to this bug.