Updated extensions corrupted profile chome data, Browser unresponsive [@ nsImageBoxListener::FrameChanged ]

RESOLVED WONTFIX

Status

()

Toolkit
Application Update
--
critical
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: Nicholas Hester, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash, dataloss})

1.7 Branch
x86
Windows XP
crash, dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

After upgrading to 1.0.3 I upgraded a few extentions that were available. I
resized my browser window using the web developer extension. On the next load of
firefox a few extentions were not displaying. Restarted in safe mode then
normally and browser stoped responding showing no page and user interface mostly
blank. Eventually corrupting my profile data. I found out it is the
Chrome.rdf.old and Chrome.rdf.new files creating a conflict.

Reproducible: Always

Steps to Reproduce:
1. Update to 1.0.3 and backup Chrome.rdf files
2. Update extensions
3. Resize browser
4. Restart browser several times until extensions in status bar start to disappear
5. Restart until failure
* Reinstall does not work with corrupted profile data
6. Remove Chrome.rdf, Chrome.rdf.old, and Chrome.rdf.new files under chrome dir
in profile
7. Replace Chrome.rdf with backup (extensions will not load if regenerated)
Problem resolved


Actual Results:  
Browser failed to respond, unable to load extentions with backed up profile data.

Expected Results:  
Normal operation with extensions rendering properly

Default theme. Problem resolved after deleting chrome.rdf.old and chrome.rdf.new
files in chrome dir of profile and replacing chrome.rdf with backup prior to
extension update.
(Reporter)

Comment 1

13 years ago
Continuous profile corrption. Last crash Talkback ID TB5190944Y.

Comment 2

13 years ago
Incident ID: 5190944
Stack Signature	nsImageBoxListener::FrameChanged 8ea6c3d0
Product ID	Firefox10
Build ID	2005041417
Trigger Time	2005-04-18 22:15:22.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (002657e2)
URL visited	
User Comments	
Since Last Crash	28529 sec
Total Uptime	92285 sec
Trigger Reason	Access violation
Source File, Line No.
d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsImageBoxFrame.cpp,
line 858
Stack Trace 	
nsImageBoxListener::FrameChanged 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsImageBoxFrame.cpp,
line 858]
imgRequest::FrameChanged 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/modules/libpr0n/src/imgRequest.cpp,
line 339]
nsTimerImpl::Fire 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 395]
nsAppShellService::Run 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
main 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)


*** This bug has been marked as a duplicate of 280009 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
the fix for bug 280009 did not make it to the branch so its unlikeley that it
fixed something ;-) on aviary
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

13 years ago
Keywords: crash, dataloss

Updated

13 years ago
Summary: Updated extensions corrupted profile chome data, Browser unresponsive → Updated extensions corrupted profile chome data, Browser unresponsive [@ nsImageBoxListener::FrameChanged ]

Updated

12 years ago
Version: unspecified → 1.0 Branch
Closing out bugs in the old style updater, which are superseded by the new system
in 1.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
Crash Signature: [@ nsImageBoxListener::FrameChanged ]
You need to log in before you can comment on or make changes to this bug.