scroll on auto overflow div

VERIFIED DUPLICATE of bug 97283

Status

()

VERIFIED DUPLICATE of bug 97283
14 years ago
14 years ago

People

(Reporter: courriel, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

On division with the style="overflow:auto;" the scroll wrong badly:
pg up and down, arrow up and down, the scroll on the mouse doesn't work :(

PS: on Linux I have the same problem

Reproducible: Always

Steps to Reproduce:
1. Open the page
2. Click on the division to be sure that it isn't a focus problem
3. Use the scroll, pg up and down key or arrow up and down key

Actual Results:  
nothing 

Expected Results:  
The division scroll up and down

sample code:
<html>
<header>
<title>test</title>
<style>
.codebox {BACKGROUND: #f5eddc} 
.incqbox H4 {PADDING-LEFT:10px}
.scrollbox {WIDTH: 100%; OVERFLOW: auto}
</style>
</header>
<body>
<p>
Voici mon XF86Config-4</p><div class="codebox"><div
class="incqbox"><h4>Code:</h4><div class="scrollbox" style="height:
35em;"><pre># XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 &gt;/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
    FontPath    "unix/:7100"            # local font server
    # if the local font server has problems, we can fall back on these
    FontPath    "/usr/lib/X11/fonts/misc"
    FontPath    "/usr/lib/X11/fonts/cyrillic"
    FontPath    "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/Type1"
    FontPath    "/usr/lib/X11/fonts/CID"
    FontPath    "/usr/lib/X11/fonts/Speedo"
    FontPath    "/usr/lib/X11/fonts/100dpi"
    FontPath    "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
    Load    "GLcore"
    Load    "bitmap"
    Load    "dbe"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "record"
    Load    "speedo"
    Load    "type1"
    Load    "v4l"
    Load    "vbe"
    Load    "xtt"
EndSection
...
</pre></div></div></div><p>Merci
de ...
</p>
</body>
</html>

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.