Closed Bug 290953 Opened 20 years ago Closed 19 years ago

sunbird alarm sound works but has speaker pop sound at beginning

Categories

(Calendar :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 68804

People

(Reporter: eneafse, Assigned: mostafah)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

I downloaded the most recent versions of sunbird for my linux system (GTK2 XFT).
It works fine, but when alarm sound plays it begins with a nasty speaker pop
sound.  I extracted sound.wav from calendar.jar.  I don't get a speaker pop when
I enter "play sound.wav" or "xmms sound.wav".  I do get the pop if I convert
sound.wav to sound.au and then enter "cat sound.au > /dev/audio".  The pop goes
away when I enter "sox sound.au -t ossdsp /dev/dsp" or "sox sound.au -t ossdsp
/dev/audio".  I hope this helps.

It also would be nice if sunbird would play mp3 files, since they are so much
smaller than wav files.  I like having a song start up to announce the alarm.

Thanks for program.

E.J. Neafsey

Reproducible: Always

Steps to Reproduce:
1. Just set "Play a sound" option for Alarms
2.
3.

Actual Results:  
speaker pop followed by beep

Expected Results:  
beep
Likely this bug can be safely duped to bug 68804
The RFE bug for a custom alarm sound has been fixed.  This should solve the 
problem on this bug in a more general way.  I'm not opposed to duping against 
bug 68804 either.  EJ, can you make a decision on this and resolve this bug one 
way or the other?

*** This bug has been marked as a duplicate of 68804 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.