Firefox process cpu utilization jumps to 100% when laptop switches from wired to wireless ip address

RESOLVED DUPLICATE of bug 213637

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 213637
14 years ago
13 years ago

People

(Reporter: kkg, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050418 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050418 Firefox/1.0+

I have a corporate IBM ThinkPad T42 laptop with Windows XP installed.
I can consistently reproduce the following problem:
1. I power on and boot a laptop on the docking station
2. I start the Firefox, visit a few pages (doesn't matter what pages) 
3. I remove a laptop from the docking station, so it switches to the wireless
network from wired network
4. Firefox process starts using 99-100% of the cpu utilization. 

This happens ALWAYS when I switch from wired to wireless network. I haven't had
this issue with Mozilla or IE. I have tried to use the latest nightly build of
the Firefox (20050418) without any luck. I also did a search on existing bugs
and don't see any describing the same simptoms.

Reproducible: Always

Steps to Reproduce:
1. connect a laptop (with wireless capabilities) to the wired network
2. open a few web-pages in the FireFox
3. disconnect a laptop from the wired network so it would switch to the wireless


Actual Results:  
Firefox process would use 99-100% cpu utilization, so the laptop is pretty much
unusable until I kill Firefox process

Expected Results:  
do not use 100% cpu utilization, it is bad. ;-)

Comment 1

14 years ago
I experience a related problem.  If I suspend my laptop and then bring it up
again, the running firefox process begins to consume 100% cpu and needs to be
killed.  Often, the suspension and resumption entails switching networks, or
losing a network entirely.

Comment 2

14 years ago
Should have mentioned that I have a Dell Latitude with XP SP2.  Firefox 1.0.3.

Comment 3

14 years ago
I have HP Pavillion ze4700 laptop with Windows XP home edition and SP2.
I observe the same issue with FireFox 1.0 on regular basis.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Reporter

Comment 5

14 years ago
The problem is still there in 1.0.7 version of Firefox.
I know a lot of people hitting this problem, and since it happens in the
corporate environment it is definitely worth fixing it.

Comment 6

14 years ago
(In reply to comment #5)
> The problem is still there in 1.0.7 version of Firefox.
> I know a lot of people hitting this problem, and since it happens in the
> corporate environment it is definitely worth fixing it.

And in Firefox 1.5 beta 2 (which is what the auto-reolve mail wanted to know) ?
Reporter

Comment 7

14 years ago
I downloaded FireFox 1.5 beta 2 and testing it now.
Give me a few days and I will report results.
Reporter

Comment 8

14 years ago
the problem is still in Firefox 1.5 Beta 2...
:-(

Removing a laptop from the docking station, so it switches from LAN ip to
wireless ip, causes Firefox to consume all CPU resources....

Comment 9

14 years ago
(In reply to comment #8)
> the problem is still in Firefox 1.5 Beta 2...
> :-(
> 
> Removing a laptop from the docking station, so it switches from LAN ip to
> wireless ip, causes Firefox to consume all CPU resources....

I have an IBM T42p which runs me into the same situation. Firefox has problems coming back from hibernate and races to consume the processor. Could be networks. There is a similar, return from hibernate, screen compositing problem that i am now starting to see. 

Someone should look into whether this problem is exacerbated by Access Connections?

Still unresolved in 1.5r2. I agree with stan, this one needs attention, i have quite a few friends with IBMs, we still use firefox....

Comment 10

14 years ago
(In reply to comment #5)
> The problem is still there in 1.0.7 version of Firefox.
> I know a lot of people hitting this problem, and since it happens in the
> corporate environment it is definitely worth fixing it.

I have an IBM R50 laptop running Windows XP, and this is a constant problem for me. It happens with both Firefox and Thunderbird. Whenever I return from standby, half of the time I have to kill the Firefox process because it is consuming the entire CPU. It makes it so that it is faster to re-boot than to use standby mode, which is extremely irritating.

Comment 11

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
 
I have a Dell Inspiron 8600 with WinXP Sp2 installed.

1. The laptop is connected to internet via network cable.
2. Open Firefox and browse the net.
3. Unplug the local area connection, while Firefox is running, then reconnect. (using the same IP adress or dynamic, doesnt matter)
4. Firefox process starts using 99-100% of the cpu 

 Reproducible: Always
 
Steps to Reproduce:
1. connect a laptop to the network via cable
2. open a few web-pages in the FireFox
3. unplug and re-plug the network cable.

Actual Results:  
 Firefox process would use 99-100% cpu utilization, so the laptop is pretty much
 unusable until I kill Firefox process
 
 Expected Results:  
 do not use 100% cpu utilization, it is bad. ;-)

--

Just confirming the OP with a similar bug, another Firefox build as well.

Comment 12

14 years ago
Confirmed, based on the duplicates. I have a HP laptop, but I never saw this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

14 years ago
This may be related to bug 265172 and bug 311810.
I can report that my Firefox 1.5 (Build 2005111116) does often have 95% CPU after resuming from suspend mode.

Comment 14

13 years ago
(In reply to comment #13)
> This may be related to bug 265172 and bug 311810.
> I can report that my Firefox 1.5 (Build 2005111116) does often have 95% CPU
> after resuming from suspend mode.
> 
I have this problem for a long time whenever my internet connection breaks and it is true for either my desktop or  notebook. It even happens for a blank page. I just have to unplug the network cable for several seconds to reproduce it.
(I am using Firefox 1.5.0.2 Windows XP Pro or Windows 2000 )

*** This bug has been marked as a duplicate of 213637 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Firefix process cpu utilization jumps to 100% when laptop switches from wired to wireless ip address → Firefox process cpu utilization jumps to 100% when laptop switches from wired to wireless ip address
You need to log in before you can comment on or make changes to this bug.