RegExp constructor does not fill in error report

VERIFIED DUPLICATE of bug 257751

Status

()

VERIFIED DUPLICATE of bug 257751
14 years ago
14 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
steps to reproduce;
1. click/load url
2. check jsconsole

actual results:
Error: invalid quantifier ?

Error: invalid quantifier ?
Source File:
data:text/html,<script>setTimeout('RegExp("?")');setTimeout('eval("/?/")');"check
js console"</script>
Line: 1
Source Code:
/?/

expected results:
actual results:
Error: invalid quantifier ?
Source File:
data:text/html,<script>setTimeout('RegExp("?")');setTimeout('eval("/?/")');"check
js console"</script>
Line: 1
Source Code:
RegExp("?")

Error: invalid quantifier ?
Source File:
data:text/html,<script>setTimeout('RegExp("?")');setTimeout('eval("/?/")');"check
js console"</script>
Line: 1
Source Code:
/?/

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 257751 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.