planet-rugby.com - drop down menus appearing behind page content

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
14 years ago
4 years ago

People

(Reporter: keith, Unassigned)

Tracking

({qawanted, testcase})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

The main page of planet-rugby has a menu bar (just under the ads at the top of
the window). Hover the mouse over any item and a drop-down list of choices
appears. However the rightmost pair of items drop down behind the panel beneath
them.

BTW: I'm using tabbed browsing.

Reproducible: Always

Steps to Reproduce:
1.Open planet-rugby.com
2.Move mouse across the green menu bar
3.

Actual Results:  
right most menus appear behind other page content and some options cannot be
selected.

Expected Results:  
Menus to appear on top of other page content
This needs a minimal testcase...
Keywords: qawanted

Updated

14 years ago
Keywords: testcase
OS: Windows XP → All
Hardware: PC → All

Comment 2

14 years ago
Created attachment 181254 [details]
Testcase

The menu items all have z-index:1, but the block that appears above them has a
z-index of 500. Therefore they appear under it.

For some reason, IE ignores the z-index:500 of the yellow block. See testcase
for reasons.

Comment 3

14 years ago
Maybe obvious, but just to be sure, the green element appears _above_ the yellow
one in IE.
Ah, ok.  So this is just a bug in IE -- it establishes a local stacking context
for the relatively positioned auto-z-index parent, looks like, which is wrong.

Over to evangelism; Mozilla's rendering here is correct.
Assignee: roc → english-us
Status: UNCONFIRMED → NEW
Component: Layout: View Rendering → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: ian → english-us
Summary: drop down menus appearing behind page content → planet-rugby.com - drop down menus appearing behind page content
Version: Trunk → unspecified

Comment 5

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.