firefox freeze on large page

RESOLVED DUPLICATE of bug 267233

Status

()

--
critical
RESOLVED DUPLICATE of bug 267233
14 years ago
14 years ago

People

(Reporter: levente_gergely, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In the following page
http://mistral.hu/arlista_kozos.html
firefox (1.0.3 and 04.19 nightly and mozilla nightly) is freezing while loading
the page. While loading (it takes a lot of time) the menu opening slowes down,
after minutes it takes 20-30 seconds). There is disabled Stop toolbar button.
In this time if I open another firefox process (with empty content[no page
loaded]), it is freezing too. Takes 10-20 seconds to kill firefox processes. 

Reproducible: Always

Steps to Reproduce:
1.open http://mistral.hu/arlista_kozos.html
2.try to scroll, try to open menus
3.

Actual Results:  
the menus are opening slower and slower.
process is freezing, not responding

Expected Results:  
The UI thread shouldn't be blocked by content-transfer or processing threads.
(Reporter)

Comment 1

14 years ago
another hang bugreport: 278966
but this bug affects all of mozilla and firefox builds.

Comment 2

14 years ago
This is not related to slow tables (bug 278966, bug 54542 among others).

The page is ~1.7MB and consists of ~1200 of these toplevel divs:

   <div id="PR_12006103" class="arl_even"
onclick="productWin('popup.php?id=12006103');">
                    <img src="arlista_kozos_files/ikon_info.gi" id="kep12006103"
style="float: left;" border="0" width="24">
            <div style="float: left; width: 455px;"><a href="#" class="arl_odd"
onclick="productWin('popup.php?id=12006103'); return false; "
onmouseover="sI('12006103');" onmouseout="rI('12006103');">ALAPLAP ASUS A7N8X
SOCKETA NVIDIA DDR ATX</a></div>
            <img src="arlista_kozos_files/s.gi" height="1" width="1">
                
            <div style="float: left; width: 38px;">16.808</div><div
class="arl_brutto">21.010</div>
                                        
            <img src="arlista_kozos_files/ikon_pipa.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" alt="" align="right"
height="11" hspace="5" vspace="0" width="12">
            <img src="arlista_kozos_files/ikon_x.gi" height="11" hspace="5"
vspace="0" width="12">
            </div>

Each line is a fixed-width <div>, containing a number of fixed-width float:left
elements, thereby looking like a table. 

Rendering takes several minutes with current 1.8b2 cvs head, a couple of seconds
in IE6.
OS: Windows XP → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 267233 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.