Last Comment Bug 291126 - intrinsically sized (shrink-wrap, auto-width) absolutely positioned element containing right float is too wide
: intrinsically sized (shrink-wrap, auto-width) absolutely positioned element c...
Status: VERIFIED FIXED
[reflow-refactor]
:
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
: 315334 (view as bug list)
Depends on: 69745 reflow-refactor
Blocks: acid2
  Show dependency treegraph
 
Reported: 2005-04-20 04:53 PDT by Ben Fowler
Modified: 2014-04-26 03:29 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase for Acid2 Action (2.22 KB, text/html)
2005-04-20 04:57 PDT, Ben Fowler
no flags Details
simplified testcase (925 bytes, text/html)
2005-10-04 05:46 PDT, Zibi Braniecki [:gandalf][:zibi]
no flags Details
The simplest testcase (594 bytes, text/html)
2005-10-05 01:10 PDT, listy
no flags Details

Description Ben Fowler 2005-04-20 04:53:16 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050420 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050420 Firefox/1.0+

Per Bug 289480 Comment 6 ,  Bug 289480 Comment 12 ,  Bug 289480 Comment 18 , I 
enclose a testcase extracted from the Acid2 Action of the Web Standards project.

Reproducible: Always

Steps to Reproduce:
1.Like the original, it is necessary to go to the #top named anchor
2.
3.



Expected Results:  
The expected render is available at 
http://www.webstandards.org/act/acid2/reference.html
Comment 1 Ben Fowler 2005-04-20 04:57:52 PDT
Created attachment 181268 [details]
Testcase for Acid2 Action

I applaud the ingenuity of the individuals responsible for this test.
Comment 2 Zibi Braniecki [:gandalf][:zibi] 2005-10-04 05:46:41 PDT
Created attachment 198439 [details]
simplified testcase

simplified testcase
Comment 3 listy 2005-10-05 01:10:11 PDT
Created attachment 198553 [details]
The simplest testcase

The simplest testcase.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-11-07 02:12:48 PST
*** Bug 315334 has been marked as a duplicate of this bug. ***
Comment 5 Gábor Stefanik 2005-12-25 05:17:22 PST
The real problem is that right floats are placed on the right side of their highest-level container (the window) instead of the right side of their lowest-level one (the 2nd line of the face, in case of Acid2). So if the screen (resolution=1024*768, browser window is considered fullscreen, margins are all set to zero, for simplicity) contains a 100*100 block that contains a small (5*5, for example) red block drawn as a right float, the red object is drawn outside the 100*100 block, at the right edge of the screen (upper left corner: x=1019, y=0; upper right one: x=1024, 1=0), whereas the expected result would be that the block's horizontal placement respects the block, so it's upper left corner goes to x=95, y=0, and it's upper right one is rendered at x=100, y=0.
Comment 6 Ben Fowler 2006-01-01 12:03:43 PST
(In reply to comment #5)
> The real problem is that right floats are placed on the right side of their
> highest-level container (the window) instead of the right side of their
> lowest-level one 

That is the only really clear description that I have seen.

1. If a patch to obtain this behaviour were applied, would this solve
this part of the Acid 2 Test? and,
2. Is it realistic for an entrey level preogrammer to identify the 
changes needed to produce such a patch?
Comment 7 David Mears 2006-01-18 18:14:05 PST
I spent about twelve hours trying to figure out where in the code this is happening, the project is a bit too large to jump into.  If I could widdle it down to one or two files to look in, I'd attempt it.
Comment 8 Zibi Braniecki [:gandalf][:zibi] 2006-01-19 00:20:05 PST
(In reply to comment #7)
> I spent about twelve hours trying to figure out where in the code this is
> happening, the project is a bit too large to jump into.  If I could widdle it
> down to one or two files to look in, I'd attempt it.

This bug is fixed on dbaron's reflow branch (http://wiki.mozilla.org/Gecko:Reflow_Refactoring)

Comment 9 sendmail.to 2006-03-14 16:31:38 PST
(In reply to comment #8)

> This bug is fixed on dbaron's reflow branch
> (http://wiki.mozilla.org/Gecko:Reflow_Refactoring)
> 

In that case this Bug should be assigend to dbaron?
Comment 10 Peter van der Woude [:Peter6] 2006-12-08 14:41:54 PST
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
Comment 11 David Baron :dbaron: ⌚️UTC-10 2006-12-08 14:51:53 PST
Fixed on trunk by reflow branch landing.
Comment 12 Aaron Kaluszka 2006-12-09 10:00:09 PST
v
Comment 13 Ryan VanderMeulen [:RyanVM] 2006-12-11 12:54:06 PST
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.

Note You need to log in before you can comment on or make changes to this bug.