After viewing a site using the embedded Windows Media Player plugin, Firefox crashes on browser exit. [@ wmp.dll + 0x21e7a4 (0x0789e7a4) 5d791558 ]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
14 years ago
3 years ago

People

(Reporter: FirefoxSupport, Assigned: bugzilla)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I hae been receiving this problem since 1.0, but don't use a lot of the embedded
WMP. I'm on Windows 2000, with WMP 9 (The latest I can go.) I installed the
plugin following the instructions on the Firefox Support Forum here:
http://forums.mozillazine.org/viewtopic.php?t=206216

Everything loads and plays fine, but once I go to exit Firefox, the window
closes, but almost immediately following the following error comes up:

"
The instruction at  "0x0789e7a4" referenced memory at "0x077319bc". The memory
could not be "written"
Click OK to terminate the program.
"

This has happened over many complete reformats as well.

Reproducible: Always

Steps to Reproduce:
1. Go to a site using an embedded WMP object such as
http://www.acidplanet.com/artist.asp?PID=534408&T=6391 and clicking "Play Song"
to the right of the page.
2. Let the WMP plugin load and play for a little, then close both Firefox windows. 

Actual Results:  
The error pops up along with the Quality Feedback Agent behind it.

Expected Results:  
Closed out cleanly without error.

Theme: I was using both noia 2 extreme and Phoenity, so I don't think it's theme
specific.
(Reporter)

Comment 1

14 years ago
My Talkback Incident ID is TB5225032G
Summary: After viewing a site using the embedded Windows Media Player plugin, Firefox crashes on browser exit. → After viewing a site using the embedded Windows Media Player plugin, Firefox crashes on browser exit. [ @ wmp.dll + 0x21e7a4 (0x0789e7a4) 5d791558 ]

Comment 2

14 years ago
Could you please try to reproduce this with a devellopement build. Get it here :
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
 .
Severity: major → critical
Component: General → Plug-ins
Product: Firefox → Core
Version: unspecified → 1.7 Branch
The stack indicates that WMP plugin itself seems to cause the crash.
(Reporter)

Comment 4

14 years ago
(In reply to comment #2)
> Could you please try to reproduce this with a devellopement build. Get it here :
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
>  .

Yes. I did try. The WMP plugin was already installed, and I installed the
ActiveX plugin like Vectorspace says on the forum posting (the same process I
used in 1.0.x). 

I loaded the page up, and immediately noticed a different-looking version of
WMP. It looked like the older versions, just black and white, simple. No fancy
skins or anything. But closing worked fine, no errors.

Was the difference in appearance of the player what solved it? I'm interested
why it looks so different.

Thanks.

Comment 5

14 years ago
Marking wfm since it is working for everyone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

14 years ago
So Gabriel,

Do I just wait until 1.1 comes out for the fix to this and just deal in the
meantime?

Updated

9 years ago
Summary: After viewing a site using the embedded Windows Media Player plugin, Firefox crashes on browser exit. [ @ wmp.dll + 0x21e7a4 (0x0789e7a4) 5d791558 ] → After viewing a site using the embedded Windows Media Player plugin, Firefox crashes on browser exit. [@ wmp.dll + 0x21e7a4 (0x0789e7a4) 5d791558 ]

Updated

9 years ago
Component: Plug-ins → Windows Media Player (Microsoft)
Product: Core → Plugins
QA Contact: general → microsoft-wmp
Version: 1.7 Branch → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.