If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When there is a new line after the opener tag and one before the end tag it display a space after.

RESOLVED DUPLICATE of bug 2750

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 2750
13 years ago
4 years ago

People

(Reporter: Michael Muryn, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

By going to the page I gave as reference:

http://www.emf.net/%7eestephen/htmlner/whitespacebugs.html

It shows four example:

<P>
<U>1. This text is underlined with no carriage returns.</U>
<BR>

<U>
2. This text is underlined with carriage returns before and after.
</U>
<BR>

<U>
3. This text is underlined with a carriage return before.</U>
<BR>

<U>4. This text is underlined with a carriage return after.
</U>

---

Strangely, only the 2nd one show a space at the end (for a newline), while the
4th one doesn't show a space.

Reproducible: Always

Steps to Reproduce:
Please see the details I gave, it is about HTML code interpreter.
Actual Results:  
There is a space inserted before the closing element for the 2nd example while
rendering the HTML.

Expected Results:  
No space inserted before the closing element for the 2nd example while rendering
the HTML.

Updated

13 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.0 Branch

Updated

13 years ago
Whiteboard: DUPEME
The problem here is that HTML isn't really sure whether it's a document language
(markup describes content model) or a layout language (markup describes
presentation).  If the latter, it's not compatible with CSS (and Mozilla is a
CSS browser, with HTML implemented in terms of CSS).  If the former, then it's
implying that those spaces should be removed from the DOM... which is not a
layout issue.
Assignee: nobody → parser
Component: Layout → HTML: Parser
QA Contact: layout → mrbkap

*** This bug has been marked as a duplicate of 2750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.